Avaya IP phone

Unanswered Question
Jun 11th, 2007
User Badges:

We have several Avaya IP phone connected to Cisco 3500 switches,


here's the port configuration we currently have


interface fast 0/1

switchport access vlan 10

switchport voice vlan 20

switchport mode access

speed 100

duplex full

spantree portfast

!

Is that right to have the command "Switchport mode access" on the interface? Will that cause problems?


Thanks in advance..

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Rob Huffman Mon, 06/11/2007 - 05:50
User Badges:
  • Super Blue, 32500 points or more
  • Hall of Fame,

    Founding Member

  • Cisco Designated VIP,

    2017 IP Telephony, Unified Communications

Hi Ahmed,


I have not used Avaya IP Phones but I did come across a thread with an answer to these questions from Kleo. There is Switchport and QoS recommendations for Avaya phones using Cisco Switches (**it looks like Switchport mode access is the recommended config);


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=Video%20over%20IP&CommCmd=MB%3Fcmd%3Dpass_through%26location%3Doutline%40%5E1%40%40.1dd98f89/0#selected_message


Hope this helps!

Rob


royalblues Mon, 06/11/2007 - 13:24
User Badges:
  • Green, 3000 points or more

Ahmed,


Though it is a valid config, i have seen people explicitly configuring a trunk when connecting an avaya phone.


sample configuration


interface range FastEthernet1/0/1

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 20


Have a look at the attached document


HTH, rate if it does

Narayan




bberry Tue, 06/12/2007 - 05:23
User Badges:

I am in the process of deployong an Avaya IP Office phone system. The config you have is designed to allow voice traffic on one VLAN and data traffic on the other. The Switchport access is the data VLAN and the switchport voice is the voice VLAN. This is based upon the documentation I have been reading. I will know today of that is not correct as the rest of the phone system hardware should be connected and configured today.

johnsonk1024 Tue, 06/19/2007 - 07:27
User Badges:

We currently have 5 campuses using Avaya phones. We have a similar configuration on our switchports.


interface GigabitEthernet1/9

switchport

switchport trunk native vlan 2

switchport trunk allowed vlan 2,3

switchport mode trunk

switchport nonegotiate

switchport voice vlan 3

no ip address

mls qos trust dscp


This may be a little late, but hope it helps others.

bberry Tue, 06/19/2007 - 08:11
User Badges:

Thanks for the info .. everyone has been a help. The deployment from an IP standpoint has been relatively smooth. The issue has been with folks having hubs/switches in their offices. Is working fine attaching the hubs to the data port on the IP phones.

Actions

This Discussion