OSPF advertising MASK configured on interface

Unanswered Question
Jun 11th, 2007
User Badges:

Hello,


I have the following configured


fr_hub#sh run int s0/0.201

Building configuration...


Current configuration : 124 bytes

!

interface Serial0/0.201 point-to-point

ip address 202.2.2.1 255.255.255.252

frame-relay interface-dlci 201 IETF

fr_hub#sh run | b router ospf

router ospf 1

log-adjacency-changes

network 202.2.2.0 0.0.0.3 area 0


and on the spoke...


spoke1#sh run int s0/0.1

Building configuration...


Current configuration : 120 bytes

!

interface Serial0/0.1 point-to-point

ip address 202.2.2.2 255.255.255.0

frame-relay interface-dlci 101 IETF


spoke1#sh run | b router ospf

router ospf 1

log-adjacency-changes

network 202.2.2.0 0.0.0.3 area 0


Now of course these interfaces are type:

POINT TO POINT, but for some reason the hub is seeing this route....


fr_hub#sh ip route ospf

202.2.2.0/24 is variably subnetted, 2 subnets, 2 masks

O 202.2.2.0/24 [110/3570] via 202.2.2.2, 00:05:49, Serial0/0.201


So, the spoke is telling the HUB the /24 on the point to point link.


Why is the hub believing the spoke has more information about the point to point link that it has? or is the hub just learning the spoke's network lsa.


thanks,


Joe

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Edison Ortiz Mon, 06/11/2007 - 07:53
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Your spoke has an incorrect subnet mask so it will cover networks other than 202.2.2.1-.2.


You can verify with show ip os database on both routers.

purohit_810 Mon, 06/11/2007 - 10:39
User Badges:
  • Silver, 250 points or more

Hi Joe,


It will always get subnetmask i.e. configured at Interface.


If you are looking concept wise.... there is priority. Interface priority is more than OSPF.



royalblues Mon, 06/11/2007 - 11:09
User Badges:
  • Green, 3000 points or more

Actually the Hub sees the /30 route as a connected route and learns the /24 route from the spoke due to mask configured on the interface.


The wildcard mask you used under the network command enables ospf on the P2P interface and as said above ospf advertises the interface mask along with the subnet to hub.


Actually if you do a sh ip route at the spoke, you will see /24 route as connected and the /30 as one learned from OSPF from the Hub.


HTH, rate if it does

Narayan

jbrunner007 Mon, 06/11/2007 - 11:52
User Badges:

Exactly guys, thanks!


I purposely configured this all this way just to understand


ospf mask behavior vs. the subnet configured on the interface... (i'm taking the lab very soon)


Any thing else would be awesome!

Actions

This Discussion