VoIP configuration

Unanswered Question
Jun 11th, 2007


i have a 7960 Ip phone and a pc connected on its access port. All i want to use QoS in order to give priority to voice traffic, so i made this configuration for one interface and i would like to know if it has a meaning(3500XL switch) ...

switchport access vlan 10

switchport voice vlan 20

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan 10

mls qos trust cos


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (2 ratings)
royalblues Mon, 06/11/2007 - 13:35


You do not require to configure a trunk between the switch and a cisco IP phone.

All you need is

switchport access vlan 10

switchport voice vlan 20

switchport trunk native vlan 10

mls qos trust cos or DSCP

A specialized trunk will be negotiated between the switch and the phone capable of carrying only 2 vlans,one for data and one for voice and this is recommended by cisco.

Also make sure you trust the QoS settings on the upstream switch trunks.

Configuration provided by you is mostly used when connecting an avaya ip phone to a cisco switch

HTH, rate if it does


bkoum Mon, 06/11/2007 - 21:14

thanks for the replay

i found an opportunity to give a try with one phone (7911 ) without the trunking port command and the phone confiuration seems not to procced . stays at registering situation without a responce.

is there anything else i have to look?


royalblues Mon, 06/11/2007 - 21:38

Trunk configs are definitely not required.


you can check the status of the port by issuing show interface fastEthernet x/y switchport

you should see the voice vlan and the trunk options

can you try connecting a working phone i.e the one which is already registered to CCM

HTH, rate if it does


bkoum Mon, 06/11/2007 - 23:13

thats the output .....

YPP-SW-3#sh int fa 0/37 switchport

Name: Fa0/37

Switchport: Enabled

Administrative mode: static access

Operational Mode: static access

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 113 (VLAN0113)

Trunking Native Mode VLAN: 113 (VLAN0113)

Trunking VLANs Enabled: NONE

Pruning VLANs Enabled: NONE

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: 10

Appliance trust: none

shows trunking disable. is it possible the old IOS ver to cause this?

royalblues Mon, 06/11/2007 - 23:29

Have you disabled CDP by any chnace on the interface?

Be aware that the special-case 802.1Q trunk automatically is enabled through a CDP information exchange between the switch and the IP Phone.

Regarding QoS for voice traffic, all you have to do is enable QoS globally and make sure you trust the DSCP at the trunks and uplinks

HTH, rate if it does


nicolas.vallot Tue, 12/11/2007 - 16:48

I had a similar problem, I disabled CDP on an interface and it the iptel couldn't register anymore.

As this discussion is about trunk and uplinks I would like to know what to do if the links between the access switches and the core is L3.

Currently we use stacks of Cat3750's which have 4 fiber uplinks to a Cat6500.

We would like to enable L3 uplinks (and use EIGRP) instead of trunks uplinks. Is this possible and how ?

My understanding is that dot1Q is L2 or am I wrong ?


This Discussion