aDSL Load Balancing Problem with NAT(?)

Unanswered Question
Jun 11th, 2007

Hi,

i have tried to configure LoadBalancing to use it for DSL lines.

First, i want to do it in the LAB where there are no adsl modules so i used 3 2801 and connect them with fastethernet.

I saw an old discussion so i only configured 3 things:

a)Globally IP cef (default)

b)2 ip routes: ip route 0.0.0.0 0.0.0.0 faste 0/0 and

ip route 0.0.0.0 0.0.0.0 vlan5

c)ip nat with route map:

route-map conn1 permit 10

match interface FastEthernet0/0

!

route-map conn2 permit 10

match interface Vlan5

!

ip nat pool connection2 10.10.1.1 10.10.1.1 netmask 255.255.255.0

ip nat pool connection1 10.10.2.1 10.10.2.1 netmask 255.255.255.0

ip nat inside source route-map conn1 pool connection1 overload

ip nat inside source route-map conn2 pool connection2 overload

!

i had to use vlan 5 because it is the on;y way the 4-port switch module can act as point-to-point interface.

Seperately it works fine: i shut on interface it works, i shut the other it works. When both are up, only one is performing nat.

Any ideas?

Thanks

Anthony

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mounir.mohamed Tue, 06/12/2007 - 00:53

Try to change the default routes to point on the next-hop IP instead of the outgoing interface, like that:

IP route 0.0.0.0 0.0.0.0 1.1.1.1

IP route 0.0.0.0 0.0.0.0 2.2.2.2

OR

IP route 0.0.0.0 0.0.0.0 F0/0 1.1.1.1

IP route 0.0.0.0 0.0.0.0 Vlan5 2.2.2.2

Best Regards,

Mounir Mohamed

mokady2006 Sun, 11/04/2007 - 09:46

It have done but as a backup DSL connections..

With two aDSL wic Utilize two PPPOE connections..

If you are interested, kindly inform me to post that configuration..

I'm still trying to do load balancing, could you please inform me if you get any solution..

thanks

Kady

Arcom Co.

Actions

This Discussion