sip-ua question

Unanswered Question
Jun 12th, 2007
User Badges:

Hi All


I could use some help setting up CM with my sip-provider.


I've setup sip-ua to connect to and authorise with my sip provider. I have setup my first handset with secondary number (same as username provided by my sip providers) and used the no-reg primary option.


Everything is working fine incoming and outgoing.


My problem is how to add more handsets. As they each need a separate username and password to register with the sip provider.


I tried adding credentials i.e. username 1301 password abcd, username 1302 password abcd etc. under sip-ua and this allows the handsets to register correctly and to receive incoming but now outgoing calls no longer work. If I remove the other registrations so only one handset registers then all handsets can make outgoing calls but only one can receive them.


I believe that using pots dial-peers to do the registrations may help but don't know how to do it.


Any help much appreciated.



Anthony


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
anthonyfear Tue, 06/12/2007 - 07:35
User Badges:

Thanks for the link - it confirms that my config is along the right lines - but the thread is not resolved either.

paolo bevilacqua Tue, 06/12/2007 - 07:53
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


please send IOS version, configuration for when the problem occours, and a trace with "term mon" and "debug ccsip message".

anthonyfear Wed, 06/13/2007 - 01:42
User Badges:

with sip-ua configured as such:


sip-ua

authentication username 1307 password xxxx

no remote-party-id

registrar ipv4:x.x.x.x expires 3600

sip-server ipv4:x.x.x.x


and a dial-peer :

dial-peer voice 100 voip

translation-profile outgoing PSTN_Outgoing

destination-pattern 9T

session protocol sipv2

session target ipv4:x.x.x.x

session transport udp

dtmf-relay rtp-nte sip-notify

no vad


all extentions are able to call out. However only the one extention (1307) is able to receive direct dial.


So under sip-ua, I tried adding


credentials username 1308 password xxxx realm xxx


however as soon as do that - I can see both extentions register with my itsp but no extentions are able to call out using the above dial-peer but direct dial works to both the numbers.


IOS 124-9.T1



paolo bevilacqua Wed, 06/13/2007 - 15:30
User Badges:
  • Super Gold, 25000 points or more
  • Hall of Fame,

    Founding Member

Hello,


can you try adding realm to authentication ?

Failing that, can you upgrade to 12.4(11)XJ3 ?

Failing that, please send output of "debug ccsip mesage" when placing a SIP call.

Actions

This Discussion