Internet connection failover??

Unanswered Question
Jun 13th, 2007

I am trying to create a redundant internet connection in one of my offices. I have a 2600 series with 2 ethernet interfaces, one connected to the local LAN segment with firewall etc., and the second connected to another switch with another firewall on it that is connected to a DSL router. If I unplug the internet connection on the first firewall, the router never switches over to the other internet connection. Havent done anything else to the config so it is as simple as can be. Here is the router config:

Current configuration:

!

version 12.1

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname dania

!

enable password xxxxx

!

!

!

!

!

ip subnet-zero

!

!

!

!

!

!

interface FastEthernet0/0

ip address 192.168.45.254 255.255.255.0

duplex auto

speed auto

!

interface Serial0/0

no ip address

encapsulation frame-relay IETF

shutdown

no fair-queue

!

interface FastEthernet0/1

ip address 192.168.0.254 255.255.255.0

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 192.168.45.1

ip route 0.0.0.0 0.0.0.0 192.168.0.1 250

no ip http server

!

!

line con 0

transport input none

line aux 0

line vty 0 4

password xxxxx

login

!

no scheduler allocate

end

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Richard Burts Wed, 06/13/2007 - 07:29

Frank

The issue is that for the floating static to be used the primary static route must be withdrawn from the routing table. The static route would be withdrawn from the routing table if the interface line protocol changed to down. But since the primary static route is over interface FastEthernet 0/0 the question becomes will the interface line protocol go down if you unplug the internet connection on the primary path. And generally the answer is that the FastEthernet interface line protocol will not go down if the outbound connection gets unplugged.

The answer to this issue is a feature called Reliable Static Routes with Object Tracking. This link should give you information to get started with it:

http://www.cisco.com/en/US/products/sw/iosswrel/ps5413/products_feature_guide09186a00801d862d.html

HTH

Rick

tntadmin Wed, 06/13/2007 - 07:56

Thanks for the reply.

That manual helps alot. But, RSR requires 12.3 I would have to upgrade the router since it is at 12.1. Is that the only way?

Regards

Frank

Richard Burts Wed, 06/13/2007 - 08:36

Frank

The only other alternative that I can think of would be to run some dynamic routing protocol. In using static routes, getting static routes over Ethernet interfaces to recognize loss of connectivity to the remote device is problematic until you get to Object Tracking and 12.1 does not have it.

So as I see it the choices are code upgrade, or use a dynamic routing protocol, or not have effective failover. I recognize that none of these may be attractive choices, but I believe that this is the reality of the situation.

HTH

Rick

Actions

This Discussion