dhcp server relay agent problem

Answered Question
Jun 13th, 2007

I have looked through past posts with out finding the resolution to my problem. Hopefully some here who knows more than I do will be able to help me out.

So here it goes....

I have a multilayer switched network.

-Dual 4507s acting as the core/distribution

-3750s connected to the collapsed backbone acting as L-2 access edge switches.

The 3750s are segmented with different vlans for each floor of the bldg.

The SVIs on the ccore 4507s have an ip helper address to relay the dhcp broadcast traffic to the dhcp server in the datacenter. This configuration is working fine. Where I'm running into problems is when end user moves from floors (into confrence rooms )to different vlans with their laptops, the dhcp address lease is not being deleted out of the dhcp database. so when the dhcp client connects to the new vlan with a different subnet, the ip address is of course in correct for the vlan. and when a "ipconfig /release & /renew" is performed the ip address is renewed. I'm guessing because of the mac address associated with the ip address in the dhcp database is the reason for this. so to get the dhcp functionality working i have to go into the dhcp server database and delete the lease and then it works. Or i have to wait for the lease to expire.

So my questions are:

1.) is there a better way that i should set this up?

2.) If i have architected the networking pieces correctly is there a way to make this work more efficiently?

*CONFIG*

4507 One VLAN

interface Vlan120

description "2nd Flr Data"

ip address 10.1.120.2 255.255.255.0

ip helper-address 10.1.3.4

standby 120 ip 10.1.120.1

standby 120 priority 110

standby 120 preempt

end

3750 One port config

interface FastEthernet4/0/36

switchport access vlan 120

switchport trunk encapsulation dot1q

switchport mode dynamic desirable

switchport voice vlan 121

spanning-tree portfast

I have this problem too.
0 votes
Correct Answer by bs6825 about 9 years 5 months ago

Sorry, my hands were moving faster than my mind..... I said that you may have issues with your DNS server, I meant DHCP. I am by no means an expert on DHCP servers, but have been biten by them many times. One thing I have seen is improper static associations of MAC addresses to IP. The fact that by going to the DHCP server to fix this is further indication that you have a problem there.

Can you get a packet capture from the workstation when doing the release/renew. Look to see if the DHCP server is responding with the proper offer. This should isolate the problem.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
bs6825 Wed, 06/13/2007 - 13:28

A couple thoughts:

Could be a problem with your DNS server or workstation configurations.

I have seen this type of behavior when a hub is incorrectly plugged into the network causing vlan and spanning tree issues. Look for mac addresses showing up in multiple places.

You did not include the config from the second access switch. I presume that it has different vlans (i.e 220/221). If they are 120/121 what you see is expected.

Another thing to try is to specify the ports as trunks on the 3750 and put in specific allowed vlans(120 & 121).

Nathan Eger Wed, 06/13/2007 - 14:00

thanks for the input. I will give the trunking piece a try on the access ports. The second stack of access switches are in different vlans

any thoughts on what to look for on the server systems?

- On DNS, what maybe isnt working like it should I'm assuming?

-any specific workstation dhcp options that should or should not should be there?

Correct Answer
bs6825 Thu, 06/14/2007 - 09:54

Sorry, my hands were moving faster than my mind..... I said that you may have issues with your DNS server, I meant DHCP. I am by no means an expert on DHCP servers, but have been biten by them many times. One thing I have seen is improper static associations of MAC addresses to IP. The fact that by going to the DHCP server to fix this is further indication that you have a problem there.

Can you get a packet capture from the workstation when doing the release/renew. Look to see if the DHCP server is responding with the proper offer. This should isolate the problem.

Nathan Eger Thu, 11/13/2008 - 11:51

Fixed thise over a year ago, but thought i would post the resolution.

There ended up being a configuration issue on the DHCP server. Used the Superscope option for all subnets, instead of a single scope.

As soon as I deleted the Super Scope and added a single scope with the same ip address subnet...BAM...started working like we wanted it too.

Actions

This Discussion