cant change 7912 from SIP to SCCP

Unanswered Question
Jun 13th, 2007

I have a 7912 that was configured for SIP for a demonstration. I am trying to convert it back to Skinny, but its not cooperating. Ive created a new gkdefault.cfg file with the firmware version I want.

(upgradecode:3,0x601,0x0400,0x0100,10.0.1.1,69,0x050124A,CP7912060000SCCP050124A.sbin)

When I reset the phone it finds the gkdefault.cfg file on the tftp server, opens it, recognizes the firware version and finds it on the tftp server. The phone says it is downloading software, then reboots but comes back up with the SIP firmware and its old config. I'm at a loss right now, any ideas?

Debug output:

Jun 13 17:21:52.494: TFTP: Looking for gk000f903525a5

Jun 13 17:21:52.506: TFTP: Looking for gkdefault.cfg

Jun 13 17:21:52.522: TFTP: Opened flash:gkdefault.cfg, fd 0, size 61 for process 38

Jun 13 17:22:02.519: TFTP: Looking for gkdefault.cfg

Jun 13 17:22:02.535: TFTP: Opened flash:gkdefault.cfg, fd 1, size 61 for process 61

Jun 13 17:22:05.547: TFTP: Finished flash:gkdefault.cfg, time 00:00:03 for process 61

Jun 13 17:22:05.559: TFTP: Looking for CP7912060000SCCP050124A.sbin

Jun 13 17:22:05.647: TFTP: Opened flash:CP7912060000SCCP050124A.sbin, fd 1, size 340247 for process 61

Jun 13 17:22:17.523: TFTP: Finished flash:gkdefault.cfg, time 00:00:25 for process 38

Jun 13 17:22:28.651: DHCPD: Sending notification of ASSIGNMENT:

Jun 13 17:22:28.651: DHCPD: address 10.0.1.100 mask 255.255.255.0

Jun 13 17:22:28.651: DHCPD: htype 1 chaddr 000f.9035.25a5

Jun 13 17:22:28.651: DHCPD: lease time remaining (secs) = 86400

Jun 13 17:22:30.647: TFTP: Finished flash:CP7912060000SCCP050124A.sbin, time 00:00:25 for process 61

Paul

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
greshkop Wed, 06/13/2007 - 13:38

I tried CP7912080003SCCP070409A.sbin first, it did the same thing. I only tried the old version because I'm using CME 3.3 right now and it was the recommended version on the matrix.

Paul

Paolo Bevilacqua Wed, 06/13/2007 - 14:00

Hi Paul,

possibly the phone has previously loaded a config file with "image ID" (that is the parameter before image name) higher of what you currently have in gkdefault.cfg

Try increasing to to something like 0x070607B or any hex value bigger of what possibly was used at the time of SIP upgrade.

Also, before doing the above, try the reset sequence: power off, press and hold #, power on, wait for led to flash in pattern, release #, press in sequence 123456789*0#. This might reset the internally stored "image ID" mentioned above.

Hope this helps, please rate post if it does!

Actions

This Discussion