Upgrade possibilities for Unity 2.4.6

Unanswered Question
Jun 13th, 2007

Yeah, I know it's old.....

Here's my quandary:

I have a Call Manager 3.1.4(b) system and the above mentioned Unity system.

I want to upgrade my CCM to 3.3(5) to allow the use of newer phones.

Unity 2.4.6 isn't compatible with CCM 3.3(5), so I also have to upgrade Unity.

CCM 3.3(5) is compatible with Unity 4.0(1) through 4.1(1).

I'm not interested in unified messaging; only voicemail. My current system is licensed for 400 users and 16 ports.

My present Unity hardware (Dell 2400 with dual PIII 550MHz and six disk RAID5 array) is listed as compatible with Unity 4.0(2). Does this mean it can also be used with 4.0(5) ?

Second question:

Regardless of the hardware issue, what exactly, software-wise, would I need to purchase to upgrade Unity 2.4.6 to 4.0(5) or 4.1(1) with only voice messaging?

I see part numbers like UNITY4.X-SL16-VUP or UNITYV4-100USR=, but am unsure as to what is applicable to my situation.

Thanks in advance for any help I can get.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rob.huffman Thu, 06/14/2007 - 05:26

Hi Grant,

I have never done this upgrade but I thought I would pass along this doc in case you haven't seen it;

"The application that imports data from Cisco Unity version 2.x works correctly only through version 4.0(4)".

Upgrading a Cisco Unity 2.x System to the Shipping Version

From this good Unity doc;


Hope this helps!


GRANT GATHAGAN Thu, 06/14/2007 - 20:54

Hi Rob,

Yeah, I'd seen that.

What it boils down to: Unity 2.x is on Exchange 5.5. When you upgrade to Unity 4.0(1)-4.0(4), the process converts the message store to Exchange 2000.

Once you're in Exchange 2000, you can move to higher versions.

I'm only using VM, not UM, so my message store can remain on the same server as Unity, but that also means that I have to use Windows 2000 server and Exchange 2000; I cannot move to Windows/Exchange 2003 and remain a single server system.

In my particular case, the version of CCM I have limits my upgrade path.

The Unity-CM TSP is the main limiting factor in compatability.

Using TSP version 8.1(3), CCM 3.3(5) is compatible with Unity 3.1(1) to 4.1(1)

TAC states that Unity 4.0(4), 4.0(5) and 4.1(1) are available.

So I know that I can upgrade, but I'm unclear as to:

1) What part numbers I need to perform the upgrade.

UNITY4.X-SL16-VUP is listed as Unity, UM or VM version update to 4.X - 16 session license

UNITYV4-100USR= is listed as Unity VM, 100 users (w/16 sessions)

Do sessions in the new versions of Unity correspond to ports in the old ?

With a 400 user, 16 port system, do I need one of the first item or four of the second, or something completely different ?

It's unclear...

2) Whether or not I'll need to buy a new server.

The supported platforms lists supported servers in three groups; supporting 4.01-4.03, supporting 4.x, and supporting 4.x and 5.0. They don't show 4.0(4) or 4.0(5) seperately, so I can only guess that those two versions are lumped in with 4.x.

That list shows an HP ML370G2 with a single 1.26GHz PIII and mirrored hard drives as supporting 4.x. I would think that my 2400, with dual PIII550's and a RAID5 array would be able to handle the same, but the 2400 is only listed as compatible up to 4.0(2).

The second issue is less important than the first, but since moving Unity to a new server is a different process than upgrading an existing system, I still need to address it.




This Discussion