trunking problems between 3725 and 2940

Unanswered Question
Jun 14th, 2007

I have set the 3725 router switch card like this:

switchport trunk ecapsulation dot1q (doesn't show on config)

switchport trunk native vlan 111

switchport trunk allowed vlan 111,222

switchport mode trunk

2940 side

switchport trunk native vlan 111

switchport trunk allowed vlan 111,222

switchport mode trunk

int vlan 111 (ip add within proper range and correct subnet)

ip default gateway (ip of router vlan int)

I have this config setup with the exact same equipment at a different site that works. On both setups the software is the same. The ports are up and line protocol is down. I can place a dummy 3com switch on the line and the port/protocol on the router goes up/up. Even if I plug the 2940 into the 3com the port the 2940 trunk port is up/up.I can ping between switch/router too. But between the 3725 and the 2940 there is no activity. What am I missing?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
smothuku Thu, 06/14/2007 - 01:33

Hi ,

check the speed and duplex settings on both ends....

change the speed and duplex to 100 and full.

Pl paste the config of the devices.



jarvar832004 Thu, 06/14/2007 - 22:32

just a small thought, did you try with the auto negotiating settings on the ports, cos i had faced such a problem with 7600 routers.

glen.grant Fri, 06/15/2007 - 03:40

It looks like you are using a 16 port hwic in your 3725 . Did you set up the layer 2 vlans in the vlan database in the hwic ? If you do a

show vlan-switch do your vlans show active ? 111,222 should show up . Also make sure vtp mode is transparent and your vtp domain name matches what you are using on the 2940, this is all set in the vlan database on the router. Also on the 2940 you can only have 1 layer 3 SVI to manage the switch so you might as well get rid of the one you don't need either int vlan 222 or int vlan 111 depending on which you are using to manage the switch.

Also if you still have problems once you get the vlans and vtp domain correct instead of forcing the trunk on you could on each use "switchport mode dunamic desirable" and see if the trunk comes active . The hwic should operate like most other cisco switches , it is basically a switch on a card that fits in the router.


This Discussion