3750 error

Unanswered Question
Jun 14th, 2007


can you tell me what is the difference with following command

erase startup config

erase nvram

i run "erase startup config" after my 3750 giving error

flashfs[0]: 0 orphaned files, 0 orphaned directories

flashfs[0]: Total bytes: 15998976

flashfs[0]: Bytes used: 3072

flashfs[0]: Bytes available: 15995904

flashfs[0]: flashfs fsck took 7 seconds.

...done Initializing Flash.

Boot Sector Filesystem (bs) installed, fsid: 3


Loading "flash:c3750-ipbase-mz.122-25.SEE2.bin"...flash:c3750-ipbase-mz.122-25.S

EE2.bin: no such file or directory

Error loading "flash:c3750-ipbase-mz.122-25.SEE2.bin"

Interrupt within 5 seconds to abort boot process.

Boot process failed...

The system is unable to boot automatically. The BOOT

environment variable needs to be set to a bootable




I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Edison Ortiz Thu, 06/14/2007 - 07:13

erase startup-config and erase nvram serve identical functions.

However, the IOS listed in the bootvar is missing.

Can you post the output from typing

dir flash:

upendra07 Thu, 06/14/2007 - 07:21

can you tell me what is the difference

erase startupconfig and erase nvram

switch: dir flash:

Directory of flash:/

2 -rwx 1456 config.text

3 -rwx 5 private-config.text

15995904 bytes available (3072 bytes used)

Edison Ortiz Fri, 06/15/2007 - 14:43

Your IOS is missing. You must download a copy from Cisco and tftp to flash:

As I stated before, the commands

erase startup-config


erase nvram

perform the same task of erasing your startup config.

It seems you executed other commands and deleted the operating system from flash.

Richard Burts Thu, 06/14/2007 - 07:17


I am not sure what is going on here. But the messages that you post sound more like flash was erased than that startup-config was erased. The messages that mention:


sound like there is a startup config and that it has a boot system command pointing to this image file and it appears that there is not any valid image file in flash. These messages in particular suggest that there is no image in flash:

flashfs[0]: Bytes used: 3072

flashfs[0]: Bytes available: 15995904



royalblues Thu, 06/14/2007 - 12:10


The erase nvram: command replaced the write erase command and the erase startup-config command.

But as indicated by Rick, there doesn't seem to be an IOS present in the flash for successful bootup.

HTH, rate if it does


upendra07 Sat, 06/16/2007 - 09:37


I solved the problem. I copied image from tftp and it's working fine.


This Discussion