Aironet 1100 Radio upgrade from B to G fails.

Unanswered Question
Jun 16th, 2007

1100 running IOS 12.3(8)JA2. Upgraded the radio from b to g with AIR-P121AG-A-K9. When the AP powers up with the G radio it gives the following error message when loading 5101.img from flash tar file- Interface Dot11Radio0, failed - Radio configuration failed, cmd 1 (0,0,0) status 7F01 (1,0,0) and the 802.11G radio status shows Software Disabled and Hardware Down.

Putting the b radio back into the AP allows it to power up okay but it loads 5001.img not 5101.img...

So, the question is, is it a faulty 51001.img file or is the radio faulty?

Any thoughts?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
rob.huffman Sun, 06/17/2007 - 01:14

Hi Ian,

Here is a very similar thread from last December. It seems that the new Radio module purchased from a third party (with none of the identifying stickers) may have been intended for the wrong country (ETSI or Japan)I have seen this a number of times. Have a look;

Hope this helps! Please let us know your resolution :)


imilne Sun, 06/17/2007 - 07:25


Thanks for the reply. I had read the thread but not sure it is applicable (happy to expand if needed).

I did discover that the radio is actually a AIRMP31G although labelled 21G. What I think is happening is that when IOS tries to read certain parameters/settings in the radio during power up that they are not at the right memory locations and it gets an error. For example I can not set the power level using the CLI. It shows an incorrect list of values - <0-264783122> not the normal {1|5|20|} etc and will not accept any value, so power level is zero. When I replace the radio with the old one all the CLI syntax/values are correct and work.

Could not find out much about the 31G radio apart from it appears to be for the 1200.

Will keep everyone updated.



This Discussion