Vanishing vlans

Unanswered Question
Jun 18th, 2007
User Badges:

Hi,


I added a new vlan to a switch and then needed to allow it on port-channel interfaces. Two additions to port-channels were fine, but with the other two, when I added the new vlan

(switchport trunk allow vlan add <vlan>), the last existing vlan disappeared from the running configuration in the interface.


However, it was still present in 'show int trunk'.


Removing my new vlan from the interface, brought the other vlan back into the config.


On the interfaces where I had a problem, there were already quite a few vlans allowed. On the interfaces where I didn't have the problem, there were not so many.


Is this a cosmetic display error that will not cause a problem, or would the switch reload without the missing vlan?


Thanks in advance.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Mon, 06/18/2007 - 03:27
User Badges:
  • Purple, 4500 points or more

Probably need more info and what type of switches they are . Probably a config error or switch limitation.

srue Mon, 06/18/2007 - 05:36
User Badges:
  • Blue, 1500 points or more

post your 'show version' output.

bootjangler Mon, 06/18/2007 - 06:13
User Badges:

Here's the show ver and further down, the config of the port channel.



Switch#sh ver

Cisco Internetwork Operating System Software

IOS (tm) c6sup2_rp Software (c6sup2_rp-JSV-M), Version 12.1(5c)EX, EARLY DEPLOYM

ENT RELEASE SOFTWARE (fc1)

Synced to mainline version: 12.1(5c)

TAC:Home:Software:Ios General:CiscoIOSRoadmap:12.1

Copyright (c) 1986-2001 by cisco Systems, Inc.

Compiled Wed 28-Mar-01 17:52 by hqluong

Image text-base: 0x30008980, data-base: 0x315D0000

ROM: System Bootstrap, Version 12.1(11r)E1, RELEASE SOFTWARE (fc1)

BOOTFLASH: c6sup2_rp Software (c6sup2_rp-JSV-M), Version 12.1(5c)EX, EARLY DEPLO

YMENT RELEASE SOFTWARE (fc1)

Switch uptime is 3 years, 43 weeks, 6 days, 4 hours, 53 minutes

System returned to ROM by power-on (SP by power-on)

System restarted at 10:20:13 BST Sat Aug 16 2003

Running default software

cisco Catalyst 6000 (R7000) processor with 491520K/32768K bytes of memory.

Processor board ID SAD05520673

R7000 CPU at 300Mhz, Implementation 39, Rev 2.1, 256KB L2, 1024KB L3 Cache

Last reset from power-on

Bridging software.

X.25 software, Version 3.0.0.

SuperLAT software (copyright 1990 by Meridian Technology Corp).

TN3270 Emulation software.

28 Virtual Ethernet/IEEE 802.3 interface(s)

96 FastEthernet/IEEE 802.3 interface(s)

18 Gigabit Ethernet/IEEE 802.3 interface(s)

381K bytes of non-volatile configuration memory.

16384K bytes of Flash internal SIMM (Sector size 512K).

Configuration register is 0x2102


Switch#sh run int po102

Building configuration...

Current configuration : 301 bytes

!

interface Port-channel102

no ip address

snmp trap link-status

switchport

switchport trunk encapsulation isl

switchport trunk allowed vlan 1,80,82,83,85,88,90-92,104,105,110,116,1002-1005

switchport trunk allowed vlan add 120-139,155,156,161,165,188,300,310,406,600

switchport mode trunk

end

In the above interface example, vlan166 was added (since removed) and at that point, vlan 600 disappeared from the config.


I've just tried to replicate on available 4500 switches, but I can add as many vlans as I like without a problem. I need to find a 6000 to try it out on now.


glen.grant Mon, 06/18/2007 - 08:30
User Badges:
  • Purple, 4500 points or more

You might want to think about upgrading the code , that is absolutely ancient and may have some bugs in it . I know of no restrictions on the 6500's at least on newer code , can't say i have seen a version that old on a Sup 2 6500 . Also I am a little confused anything with code that is that old would have to be hybrid and the port channels would not be defined on the layer 3 side it would be done on the catos layer 2 side . Anyone elaborate on that ?? They didn't have native code that old that I know of.

Amit Singh Mon, 06/18/2007 - 08:40
User Badges:
  • Cisco Employee,

Seems to be a cosmetic issue with the IOS. Try upgrading it with the latest IOS in the same train that should take care of this. Its even very hard to find some bugs on such an old release.


Oh.. God this one is really old.. do you get to your switches once in a year :)..


-amit singh



bootjangler Mon, 06/18/2007 - 09:11
User Badges:

Our Cisco rep hasn't heard of any bug like this either and has just suggested replicating it in test, along with a few choice command outputs. I'm off to find a switch that can handle that old code.


I'd certainly agree with an upgrade.

Actions

This Discussion