Router giving ERROR

Unanswered Question
Jun 18th, 2007

the sh log gives me certail BADSHARE errors.. can anyone help me interpert them ??

attached is the output log

ISP says the router is broke..

what caused these errors and what do they say exactly..

Attachment: 
I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
milan.kulik Mon, 06/18/2007 - 05:37

Hi,

what about some IOS bug?

CSCsb13455, e.g.?

The CCO error message decoder says:

1. %SYS-2-BADSHARE: Bad refcount in [chars], ptr=[hex], count=[hex]

An internal software error has occurred.

Recommended Action: If this message recurs, copy the error message exactly as it appears on the console or in the system log, contact your Cisco technical support representative, and provide the representative with the gathered information.

With several links to different IOS Release Notes.

BR,

Milan

a.shaukat Mon, 06/18/2007 - 21:01

thats what i want to find out that is this a IOS error or somthing else??

im using IOS Cisco IOS Software, 2801 Software (C2801-ADVENTERPRISEK9-M), Version 12.4(3), RELEASE SOFTWARE (fc2)

does it have any bugs in that regards??

a.shaukat Mon, 06/18/2007 - 22:20

i just did a little research for the badshare error on IOS 12.4(3) and it gave me the following

=========================================

CSCei27330

Symptoms: A router that is configured for Dynamic Multipoint VPN (DMVPN) may frequently generate the following error message:

%SYS-2-BADSHARE: Bad refcount in datagram_done

Conditions: This symptom is observed on a Cisco router such as a Cisco 871 and Cisco 1800 series that function as a DMVPN spoke.

Workaround: There is no workaround.

=============================================

my running config is as under..

Router#sh run

Building configuration...

Current configuration : 3375 bytes

!

version 12.4

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname Router

!

boot-start-marker

boot system flash c2801-adventerprisek9-mz.124-3.bin

boot-end-marker

!

logging buffered 51200 warnings

enable secret 5 $1$kjhfhshkjh354hkjh45vVjf0

enable password 7 07867867C0E1625

!

no aaa new-model

!

resource policy

!

mmi polling-interval 60

no mmi auto-configure

no mmi pvc

mmi snmp-timeout 180

ip subnet-zero

ip cef

!

ip flow-cache timeout active 1

no ip domain lookup

ip domain name yourdomain.com

!

username zaid privilege 15 secret 5 $1$Yqsdfdgdgh#%#%$ghgfQ3aSe8Weau.

!

crypto isakmp policy 1

encr 3des

hash md5

authentication pre-share

group 2

crypto isakmp key hello address 192.168.93.254

crypto isakmp keepalive 10

!

crypto ipsec security-association lifetime seconds 86400

!

crypto ipsec transform-set vpntest esp-3des esp-md5-hmac

!

crypto map vpntest local-address Loopback0

crypto map vpntest 10 ipsec-isakmp

set peer 192.168.93.254

set transform-set vpntest

match address 102

!

interface Loopback0

ip address 192.168.88.252 255.255.255.255

ip route-cache flow

!

interface FastEthernet0/0

description $ETH-LAN$$ETH-SW-LAUNCH$$INTF-INFO-FE 0$

ip address 192.168.97.156 255.255.255.248

ip nbar protocol-discovery

ip route-cache flow

load-interval 30

duplex auto

speed auto

crypto map vpntest

!

interface FastEthernet0/1

ip address 192.168.2.254 255.255.255.0

ip nbar protocol-discovery

ip route-cache flow

load-interval 30

duplex auto

speed auto

priority-group 1

!

interface ATM0/2/0

no ip address

ip route-cache flow

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 0/35

pppoe-client dial-pool-number 1

!

!

interface Dialer1

ip address negotiated

ip mtu 1492

encapsulation ppp

load-interval 30

dialer pool 1

ppp pap sent-username dslbkup password 7 00675765756756E451C09

crypto map vpntest

!

router ospf 10

router-id 192.168.97.156

log-adjacency-changes

network 192.168.88.252 0.0.0.0 area 12

network 192.168.97.152 0.0.0.7 area 12

!

ip classless

ip route 0.0.0.0 0.0.0.0 222.163.88.254

ip route 0.0.0.0 0.0.0.0 Dialer1 50 name Backup

ip route 192.168.97.152 255.255.255.248 192.168.97.153

!

ip flow-export source FastEthernet0/1

ip flow-export version 5

ip flow-export destination 192.168.2.22 9996

!

ip http server

ip http authentication local

no ip http secure-server

ip http timeout-policy idle 5 life 86400 requests 10000

!

access-list 102 permit ip 192.168.2.0 0.0.0.255 192.168.0.0 0.0.0.255

access-list 102 permit ip 192.168.2.0 0.0.0.255 172.16.0.0 0.0.15.255

access-list 150 permit tcp 192.168.2.0 0.0.0.255 any range 0 10000

access-list 150 permit udp 192.168.2.0 0.0.0.255 any range 0 10000

access-list 150 permit icmp 192.168.2.0 0.0.0.255 any echo-reply

access-list 150 permit icmp 192.168.2.0 0.0.0.255 host 192.168.2.254

priority-list 1 protocol ip low tcp www

priority-list 1 protocol ip low tcp ftp

snmp-server community DW RW

snmp-server community public RO

snmp-server ifindex persist

a.shaukat Mon, 06/18/2007 - 22:24

or could it be this one ??

CSCeh22021

Symptoms: When you attempt to establish a PPP session over an ATM interface, the following error message is generated and the session is not established:

%SYS-2-BADSHARE: Bad refcount in datagram_done, ptr=440A7FA0, count=0"

Conditions: This symptom is observed on a Cisco MGX 8800 series RPM-XF that runs Cisco IOS Release 12.4 when PPP over ATM is configured. However, the symptom may also occur on another Cisco router (from the Cisco 2600 series through the Cisco 7300 series) that runs Release 12.4.

Workaround: There is no workaround.

man this IOS has some serious issues...

lol

Richard Burts Tue, 06/19/2007 - 03:27

Atif

Since you are doing PPP over ATM and are not doing DMVPN it would seem much more likely that you are hitting the second bug. And probably it matters less which bug it is, and matters more that 12.4(3) is fairly old code at this point and has this issue as well as some other recently announced vulnerabilities. You should start planning for a code upgrade for this router.

HTH

Rick

a.shaukat Tue, 06/19/2007 - 04:17

hmm probably... what is a DMVPN Spoke anyways

we are using dynamic vpn but not at this branch end.. we have it configured at the head office end and the branches initiate the tunnel..

but my real concern is that is the ISP guy right in terms that this error is "probably" causing the timeouts in the link..

i have 2 more branches with the same router but an older IOS 12.3(14)T7 and its working like a charm.. perhaps i should change this routers IOS to those older one for now..

Actions

This Discussion