Hint how to restore factory config on ASA 5505 ??

Answered Question
Jun 19th, 2007

Hi, I am new to CISCO appliances and while configuring my ASA 5505 I changed the IP address range of the internal network. Obviously I made an error because I cannot reach the box neither at the old nor the new address. How can I restore the interface and firewall definitions or reset the box to its initial state ? I found a doc how to reset the password, but not explaining how to restore the complete initial config.

Thank you for a hint, I hope there is a doc describing this process or a hint which command I should use.

I have this problem too.
0 votes
Correct Answer by anandramapathy about 9 years 5 months ago
Correct Answer by anandramapathy about 9 years 5 months ago

Try the following

hostname(config)# configure factory-default [ip_address [mask]]

If you specify the ip_address, then you set the inside or management interface IP address, depending on

your model, instead of using the default IP address of 198.168.1.1. The http command uses the subnet

you specify. Similarly, the dhcpd address command range consists of addresses within the subnet that

you specify.

After you restore the factory default configuration, save it to internal Flash memory using the write

memory command. The write memory command saves the running configuration to the default location

for the startup configuration, even if you previously configured the boot config command to set a

different location; when the configuration was cleared, this path was also cleared.

******

######

HTH - Please rate all useful posts

######

******

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 3.8 (4 ratings)
Loading.
Correct Answer
anandramapathy Tue, 06/19/2007 - 01:46

Try the following

hostname(config)# configure factory-default [ip_address [mask]]

If you specify the ip_address, then you set the inside or management interface IP address, depending on

your model, instead of using the default IP address of 198.168.1.1. The http command uses the subnet

you specify. Similarly, the dhcpd address command range consists of addresses within the subnet that

you specify.

After you restore the factory default configuration, save it to internal Flash memory using the write

memory command. The write memory command saves the running configuration to the default location

for the startup configuration, even if you previously configured the boot config command to set a

different location; when the configuration was cleared, this path was also cleared.

******

######

HTH - Please rate all useful posts

######

******

jcurdes_overspeed Tue, 06/19/2007 - 03:16

Thanks a lot. I will try asap; at the moment I am not near the router. Where could one find these commands in the docs ? I tried to look at the 2800 page command reference but afterwards I had lsee clue than before....

jcurdes_overspeed Tue, 06/19/2007 - 04:57

Well, that exactly shows the problem : I already looked at this doc before, but the index does not contain reset, factory, default or similar words; I read through several paragraphs of it and did not find a hint. This is why I asked in the first place. It seems that the info I wanted is so simple nobody bothers to write it down....

jcurdes_overspeed Tue, 06/19/2007 - 04:51

Superb; that was it. I had tried to use

config factory-default

which only gave me an error.

Thanks a lot for your quick help !!

anandramapathy Tue, 06/19/2007 - 05:01

am glad that we were able to resolve your issue. Thank you for using the rating system to indicate that your issue was resolved (and thanks for the rating). It makes the forum more useful when people can read about an issue and can be sure that they will read a solution to the issue. I encourage you to continue your participation in the forum.

jcurdes_overspeed Tue, 06/19/2007 - 05:21

Hmmm. After a reboot, ther problem is back again. I did a "write memory". Can it be I have to select a certain image ? Perhaps I already chonged something unwillingly; I tried to follow the password recovery strategy explained in

I did something like

copy startup-config running-config

config-register 0x1

Another thing is that after the reboot I could not manage my appliance to accept the

configure factory-default

again; in which mode exactly do I have to enter this command ?

Paul Santabarbara Wed, 04/06/2011 - 18:44

OK! I did what was recommended above and here is the config.

How do I get it to the point where I can use ASDM?  Please advise.

ciscoasa# sh run
: Saved
:
ASA Version 7.2(3)
!
hostname ciscoasa
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Vlan1
no nameif
no security-level
no ip address
!
interface Ethernet0/0
shutdown
!
interface Ethernet0/1
shutdown
!
interface Ethernet0/2
shutdown
!
interface Ethernet0/3
shutdown
!
interface Ethernet0/4
shutdown
!
interface Ethernet0/5
shutdown
!
interface Ethernet0/6
shutdown
!
interface Ethernet0/7
shutdown
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
pager lines 24
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
telnet timeout 5
ssh timeout 5
console timeout 0

!
!
prompt hostname context
Cryptochecksum:00000000000000000000000000000000
: end
ciscoasa#

KARUPPUCHAMY MA... Wed, 04/06/2011 - 18:53

Hi,


IF you want to configure your ASA, you have to configure the below commands and prior to that check weather the ASDM image is loaded on your flash


ciscoasa#sh flash:


Configuration:-


ciscoasa> enable
Password:
ciscoasa# configure terminal
ciscoasa(Config)# interface ethernet0/0
ciscoasa(Config-if)# nameif inside
ciscoasa(Config-if)# ip address 192.168.1.1 255.255.255.0
ciscoasa(Config-if)# no shutdown
ciscoasa(Config-if)#

Activate ASDM and enable http server.

ciscoasa(Config)# asdm image flash:/asdm.bin.
ciscoasa(Config)# http server enable.

Open a connection for your PC. Example your pc IP address is 192.168.1.2

ciscoasa(Config)# http 192.168.1.2 255.255.255.255 inside

Make sure all your config running properly.

ciscoasa(Config)# show running http
http server enabled
http 192.168.1.2 255.255.255.255 inside
ciscoasa(Config)#


Thanks

Karuppu

Actions

This Discussion