VIC2-2BRI-NT/TE

Unanswered Question
Jun 19th, 2007

We are trying to connect a matra PABX to a 2800 gateway (call-manager 4.1)

When we try from an IP-phone to contact a matraphone (extension 474) we only have a busy tone

here our gw config :

hostname GW2

isdn switch-type basic-net3

ip cef

interface FastEthernet0/0

description Gateway 2

ip address 172.16.0.13 255.255.255.128

speed 100

full-duplex

interface BRI0/0/0

no ip address

isdn switch-type basic-net3

isdn protocol-emulate network

isdn layer1-emulate network

isdn voice-priority always

isdn incoming-voice voice

isdn bind-l3 ccm-manager service mgcp

isdn skipsend-idverify

line-power

ip classless

ip route 0.0.0.0 0.0.0.0 172.16.0.1

disable-eadi

voice-port 0/0/0

cptone BE

ccm-manager redundant-host 172.16.0.11

ccm-manager mgcp

ccm-manager music-on-hold

ccm-manager config server 172.16.0.10

ccm-manager config

mgcp

mgcp call-agent 172.16.0.10 service-type mgcp version 1.0

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

no mgcp package-capability res-package

mgcp package-capability sst-package

no mgcp package-capability fxr-package

mgcp package-capability pre-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp rtp payload-type g726r16 static

mgcp profile default

dial-peer voice 1 pots

service mgcpapp

direct-inward-dial

port 0/0/0

forward-digits all

GW2#sh isdn status

Global ISDN Switchtype = basic-net3

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 0. Layer 3 output may not apply

ISDN BRI0/0/0 interface

******* Network side configuration *******

dsl 0, interface ISDN Switchtype = basic-net3

L2 Protocol = Q.921 0x0000 L3 Protocol(s) = CCM MANAGER 0x0003

Layer 1 Status:

ACTIVE

Layer 2 Status:

TEI = 0, Ces = 255, SAPI = 0, State = TEI_ASSIGNED

Layer 3 Status:

0 Active Layer 3 Call(s)

Active dsl 0 CCBs = 0

The Free Channel Mask: 0x80000003

%Q.931 is backhauled to CCM MANAGER 0x0003 on DSL 1. Layer 3 output may not apply

GW2#sh interfaces bri 0/0/0

BRI0/0/0 is up, line protocol is up (spoofing)

Hardware is Voice NT or TE BRI

MTU 1500 bytes, BW 64 Kbit, DLY 20000 usec,

reliability 255/255, txload 1/255, rxload 1/255

Encapsulation VOICE, loopback not set

Last input 02:11:15, output never, output hang never

Last clearing of "show interface" counters never

Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0

Queueing strategy: weighted fair

Output queue: 0/1000/64/0 (size/max total/threshold/drops)

Conversations 0/1/16 (active/max active/max total)

Reserved Conversations 0/0 (allocated/max allocated)

Available Bandwidth 48 kilobits/sec

5 minute input rate 0 bits/sec, 0 packets/sec

5 minute output rate 0 bits/sec, 0 packets/sec

457 packets input, 1956 bytes, 0 no buffer

Received 0 broadcasts, 0 runts, 0 giants, 0 throttles

0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored, 0 abort

2993 packets output, 22122 bytes, 0 underruns

0 output errors, 0 collisions, 14 interface resets

0 output buffer failures, 0 output buffers swapped out

32798 carrier transitions

Many thanks in advance for your answers

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
parker1956 Tue, 06/19/2007 - 23:04

sorry for the delay...

we have a big problem with call manager (it's always the same problem)

our gateway is not registered

we put several config on tftp... we tried to reload... always not registered...

we cannot try what you mentionned

I tried "isdn q931" and nothing on my screen... I forgot "term mon" (difference between console and telnet!!!)

parker1956 Wed, 06/20/2007 - 05:39

our gateway is registered !!!

gw2#sh ccm-manager

MGCP Domain Name: gw2.voip.igretec.be

Priority Status Host

============================================================

Primary Registered 172.16.0.10

First Backup Backup Ready 172.16.0.11

Second Backup None

Current active Call Manager: 172.16.0.10

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 13:33:48 UTC Jun 20 2007 (elapsed time: 00:00:04)

Last MGCP traffic time: 13:33:48 UTC Jun 20 2007 (elapsed time: 00:00:04)

Last failover time: 13:14:56 UTC Jun 20 2007 from (172.16.0.10)

Last switchback time: None

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

Backhaul Link info:

Link Protocol: TCP

Remote Port Number: 2428

Remote IP Address: 172.16.0.10

Current Link State: OPEN

Statistics:

Packets recvd: 9

Recv failures: 0

Packets xmitted: 7

Xmit failures: 0

BRI Ports being backhauled:

Slot 0, VIC 0, port 1

Slot 0, VIC 0, port 0

Configuration Auto-Download Information

=======================================

Current version-id: {9AC20902-7F05-4DD5-9E1D-BADB95C61FC4}

Last config-downloaded:00:00:00

Current state: Waiting for commands

Configuration Download statistics:

Download Attempted : 1

Download Successful : 1

Download Failed : 0

Configuration Attempted : 1

Configuration Successful : 1

Configuration Failed(Parsing): 0

Configuration Failed(config) : 0

Last config download command: New Registration

FAX mode: cisco

when I call matraphone extension 474 always busy tone

nothing on my screen with "debug isdn q931"

with "debug isdn q921" :

*Jun 20 13:35:11.431: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=44817 ai=127

*Jun 20 13:35:13.431: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=40994 ai=127

*Jun 20 13:35:15.431: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=41539 ai=127

*Jun 20 13:35:21.443: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=50804 ai=127

*Jun 20 13:35:23.439: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=11701 ai=127

*Jun 20 13:35:25.439: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=2310 ai=127

*Jun 20 13:35:31.479: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=39271 ai=127

*Jun 20 13:35:33.479: ISDN BR0/0/0 Q921: Net TX -> IDREQ ri=12248 ai=127

anyway many thanks for your help "p"

parker1956 Wed, 06/20/2007 - 12:15

we are still using this cable

crossin blue / white blue on green / white green

I'am replying from home

We'll continue to morrow in my office

Thanks

parker1956 Wed, 06/20/2007 - 23:53

phone on matra PABX (ext : 474) is calling IP phone 8422

after few seconds PABX drops the call but the IP phone remains ringing !

gw2# debug isdn q931

*Jun 21 07:51:22.851: ISDN BR0/0/0 Q931: RX <- SETUP pd = 8 callref = 0x32

Bearer Capability i = 0x9090A3

Standard = CCITT

Transfer Capability = 3.1kHz Audio

Transfer Mode = Circuit

Transfer Rate = 64 kbit/s

Progress Ind i = 0x8083 - Origination address is non-ISDN

Calling Party Number i = 0x0080, '474'

Plan:Unknown, Type:Unknown

Called Party Number i = 0x80, '071348422'

Plan:Unknown, Type:Unknown

Sending Complete

*Jun 21 07:51:22.871: Modify Nominator =

*Jun 21 07:51:22.871: DTMF_TONE_DET

*Jun 21 07:51:22.871: Modify Nominator =

*Jun 21 07:51:22.871: FAX

*Jun 21 07:51:22.871: CODEC_BYTES

*Jun 21 07:51:22.871: NTE_PAYLOAD

*Jun 21 07:51:22.871: DTMF_RELAY

*Jun 21 07:51:22.871: NSE_PAYLOAD

*Jun 21 07:51:22.875: SIGNAL_TYPE

*Jun 21 07:51:22.875: FAX_BYTES

*Jun 21 07:51:22.875: NTE_TX_PAYLOAD

*Jun 21 07:51:22.875: SEQ_NUM_START

*Jun 21 07:51:22.875: MP_CAP_MODEM_PROTO

*Jun 21 07:51:22.875: MP_CAP_MODEM_CODEC

*Jun 21 07:51:22.875: MP_CAP_VOICE_RTP_NSE_PAYLOAD

*Jun 21 07:51:22.875: MR_INFO

*Jun 21 07:51:22.875: Modify Nominator =

*Jun 21 07:51:22.875: FAX_TONE_DET

*Jun 21 07:51:22.875: MODEM_TONE_DET

*Jun 21 07:51:22.879: CM_TONE_DET

*Jun 21 07:51:22.879: PER_CALL_DEBUG

*Jun 21 07:51:22.883: Modify Nominator =

*Jun 21 07:51:22.883: DTMF_TONE_DET

*Jun 21 07:51:22.883: Modify Nominator =

*Jun 21 07:51:22.883: DTMF_TONE_DET

*Jun 21 07:51:33.003: Modify Nominator =

*Jun 21 07:51:33.003: DTMF_TONE_DET

*Jun 21 07:51:33.003: FAX_TONE_DET

*Jun 21 07:51:33.003: Modify Nominator =

*Jun 21 07:51:33.003: DTMF_TONE_DET

*Jun 21 07:51:33.003: FAX_TONE_DET

*Jun 21 07:51:36.383: Modify Nominator =

*Jun 21 07:51:36.383: DTMF_TONE_DET

*Jun 21 07:51:36.383: Modify Nominator =

*Jun 21 07:51:36.383: DTMF_TONE_DET

gw2#

Thanks !

parker1956 Thu, 06/21/2007 - 00:06

LED's status on the BRI interface card :

green OK is ON

BR1 BR2 are OFF

Paolo Bevilacqua Thu, 06/21/2007 - 00:13

Hello,

you cabling should now be OK.

Unfortunately since you are using MGCP and the trace is not complete with another debug intermingled, I can't help you much on the problem now.

Suggest you post in "ip telephony" forum. Include your config when you do.

Actions

This Discussion