Device Fault Manager - Notification Groups

Unanswered Question
Jun 19th, 2007


In Home / Device Management / Device Details I can search, making the rule expression

Device.IP.Address contains "172.16.0.", all the devices i need to investigate.

Then, from the "search result" box, I can select all the devices from "Select all" and so

I can view all the informations about those devices.

But from Notification Services / Notification Groups, selecting "Add" and


the devices with the same rule expression, I can find all my devices, but

1) I'm not able to check the "Select all"


2) Selecting one by one all the devices and, selecting the alert severitiy, the alert status, the event set, the event severity and the event status, checking "Next" this error occurs:

"The devices contained in the subscription are no longer found in the Inventory".

Then I can't see anymore the previous devices list in the "search result" box.


I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 2.8 (6 ratings)
Joe Clarke Tue, 06/19/2007 - 11:35

I can't reproduce issue 1. What browser are you using? What version of Common Services and DFM do you have installed? Issue 2 could be a problem with DFM OGS. Depending on the version of LMS, you might try running NMSROOT/bin/perl NMSROOT/MDC/tomcat/webapps/triveni/WEB-INF/classes/, restart dmgtd, and see if that helps.

Leonardo Roberto Wed, 06/20/2007 - 03:07

LMS 2.6



ie: 6.0.3x

Java: 1.4.2_10

but I have the same problem with this application changes, from another machine:

ie: 7.0.5x

Java: 6 upd.1

Using the perl script you suggest, nothing happens.

I still have the same situation,


Joe Clarke Wed, 06/20/2007 - 08:03

Please download Mozilla 1.7.13 from , and see if the first problem persists. If it does, its Javascript console may provide more details as to why the error is occurring. To access that console, go to Tools > Web Development > JavaScript Console.

Leonardo Roberto Thu, 06/21/2007 - 06:19

i've tried to use the mozilla 1.7.13 version on both the machines, the one with java 1.6upd.1 and the one with java 1.4.2_10, but the result is the same: the java console doesn't log!

Nothing solved.

Strange to view no messages on the java consoles..


Joe Clarke Thu, 06/21/2007 - 08:14

The Java console and the Javascript console are two different things. The Java console is useless here as DFM doesn't use client-sided Java at all. If you are not seeing any messages in the Javascript console, then I need to see a screenshot of the problems you are having. I've tried numerous things but I cannot reproduce your problems.

Leonardo Roberto Mon, 06/25/2007 - 03:14

Thank you, I've seen about the patch and the TAC told me to upgrade DFM to 2.0.8 first.

Thanx very much.

pvanvuuren Mon, 06/25/2007 - 04:45


I had exactly the same error: DFM devices not showing in the notifications window. I re-installed DFM, and noticed that everything worked after the re-install. But then as soon as I installed the LMS 2.6 Update ( as per Cisco's instructions ) the problem came back again. Let us know when you get a resolve.

Joe Clarke Mon, 06/25/2007 - 05:19

You need to call the TAC and get my patch for the aforementioned bug.


This Discussion