modem dialin problem

Unanswered Question
Jun 20th, 2007
User Badges:

Hi,


Hope you can help me with this, Im stuck.

I have a 2500 router with several external modems (US Robotics 56k) connected over asynch cables. the line config is setup to autocommand telnet to a backend server.


When I attempt to dial in, whichever modem answers, it seems to pick up the call, but then it drops almost immediately. The router log shows the same debug message each time:


Jun 18 14:40:20.691: tty1: Modem: HANGUP->IDLE

Jun 18 14:40:22.031: TTY1: Line reset by "Virtual Exec"

Jun 18 14:40:22.031: TTY1: Modem: IDLE->HANGUP

Jun 18 14:40:22.035: TTY1: destroy timer type 0

Jun 18 14:40:22.035: TTY1: destroy timer type 1

Jun 18 14:40:22.039: TTY1: destroy timer type 3

Jun 18 14:40:22.039: TTY1: destroy timer type 4

Jun 18 14:40:22.039: TTY1: destroy timer type 2

Jun 18 14:40:22.727: TTY1: dropping DTR, hanging up

Jun 18 14:40:22.727: tty1: Modem: HANGUP->IDLE

Jun 18 14:40:24.764: TTY1: restoring DTR

Jun 18 14:41:48.646: TTY1: Line reset by "Virtual Exec"


router config:



version 12.0

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname R1

!

logging buffered 50000 debugging

aaa new-model

aaa authentication login default local

aaa authentication login no_user enable

aaa authentication login noaut none

aaa authentication login noprompt none

enable secret 5 <removed>

!

username test password 7 <removed>

ip subnet-zero

clock timezone GMT 0

!

!

!

interface Ethernet0

ip address x.x.x.x 255.255.255.0

no ip directed-broadcast

no ip mroute-cache

!

interface Serial0

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

no fair-queue

!

interface Serial1

no ip address

no ip directed-broadcast

no ip mroute-cache

shutdown

!

ip classless

ip route 0.0.0.0 0.0.0.0 x.x.x.x

!

!

line con 0

transport input none

line 1

no exec-banner

exec-timeout 0 0

no activation-character

autoselect during-login

session-limit 1

no vacant-message

login authentication noaut

modem Dialin

autocommand telnet x.x.x.x 3001 /noecho

terminal-type edit

exec-character-bits 8

special-character-bits 8

transport preferred telnet

transport input all

escape-character BREAK

stopbits 1

flowcontrol hardware

line 2

no exec-banner

exec-timeout 0 0

no activation-character

autoselect during-login

session-limit 1

no vacant-message

login authentication noaut

modem Dialin

autocommand telnet x.x.x.x 3000 /noecho

terminal-type edit

exec-character-bits 8

special-character-bits 8

transport preferred telnet

transport input all

escape-character BREAK

telnet transparent

stopbits 1

flowcontrol hardware

line aux 0

login authentication no_user

line vty 0 4

password 7 <removed>

end




  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Wilson Samuel Wed, 06/20/2007 - 11:51
User Badges:
  • Gold, 750 points or more
  • Community Spotlight Award,

    Mobile User, July 2015

Hi,


On a similar occassion wherein I was trying to get Aux Port configured for Remote Dialin (for exec access and not for data) I tried almost 4 USR modems and everytime all the modems would get stuck at the handshake and never be able to complete the process.


However when I changed the modem to a simple make and model, it did work!


I guess its a problem with USR, have you ever tried with some other brand?


Kind Regards,

Wilson Samuel

sundar.palaniappan Wed, 06/20/2007 - 16:59
User Badges:
  • Green, 3000 points or more

It may be a problem with the dip switch setting in your USR modem.


Try setting dip switches 1, 3 & 8 down and other ones up or 3, 7 & 8 down and others up. I have used one of this settings effectively in the past.


Let us know if that helps.


HTH


Sundar

spyoung Wed, 06/20/2007 - 23:21
User Badges:

Unfortunately this modem (USR 56k fax modem) seems to have no dip switches, not externally anyway. Unless there are dip switches inside the case on the main circuit board.


I will source another modem and try that.



thanks,

Actions

This Discussion