EIGRP neighbor down; peer restarted

Unanswered Question
Jun 20th, 2007

Hi,

We wish to use eigrp to enable automatic failover for a branch's 2 links. The branch is connected to our HQ through service provider networks. We configured tunnels to have point-to-point connection for the neighbor relationship between the branch router and our HQ router. The tunel configs for the HQ Router are:

!

interface Tunnel120

description Tunnel to WestDrive Branch

bandwidth 256

ip address 172.28.1.1 255.255.255.252

ip mtu 1476

tunnel source 172.16.31.2

tunnel destination 102.0.10.21

interface Tunnel148

description Tunnel to WestDrive Branch

bandwidth 9

ip address 172.17.18.77 255.255.255.252

tunnel source 192.40.101.2

tunnel destination 109.109.109.140

The tunnel configs at the branch Router are:

interface Tunnel1

description Tunnel to HO Via Provider2

bandwidth 9

ip address 172.17.18.78 255.255.255.252

tunnel source 109.109.109.140

tunnel destination 192.40.101.2

!

interface Tunnel3

description Tunnel to HO Via Provider1

bandwidth 256

ip address 172.28.1.2 255.255.255.252

ip mtu 1476

ip bandwidth-percent eigrp 200 25

tunnel source 102.0.10.21

tunnel destination 172.16.31.2

router eigrp 200

passive-interface FastEthernet0/0

passive-interface Tunnel0

network 172.17.0.0

network 172.28.0.0

network 10.18.105.0

no auto-summary

eigrp stub connected summary

However we noticed that the branch connection became unstable as the Router toggles from one link to the other and then back again, and then fails over again after few seconds. Terminal monitor outputs on the branch router shows the following:

*Jun 20 08:06:32.615: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 172.28.1.1 (T

unnel3) is down: peer restarted

*Jun 20 08:06:33.399: %DUAL-5-NBRCHANGE: IP-EIGRP(0) 200: Neighbor 172.28.1.1 (T

unnel3) is up: new adjacency.

I'm at a loss as to why the peer gets restarted and what to do to stop it.

I also did a debug ip eigrp on the branch router and a message said: k-values mismatch but the k-values are same on both routers: k1=k3=1 the rest =0.

What could possibly be going on? Thanks for your assistance.

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
smothuku Wed, 06/20/2007 - 03:31

Hi ,

why did you configure ip bandwidth-percent eigrp 200 25 under tunnel interface of branch Router .

You want to use only 25 (i.e 64 kbps)percent of 256 kbps.

Thanks,

Satish

imuonagor Wed, 06/20/2007 - 03:59

Thanks. The link is actually a 128kbps link. We configured bandwidth 256 on the tunnel to make eigrp prefer it over the other link's tunnel.

Also the k-values mismatch message was seen from the HQ router not the branch as i earlier mistyped. The message I saw from the branch router is neighbor down; peer restarted. But I have checked from sh ip protocols and the k-values are the same at both routers: k1=k3=1; k2=k4=k5=0

Richard Burts Wed, 06/20/2007 - 05:26

Actually the K value mismatch message is a reflection of the fact that the 2 routers have different versions of code. On the router running newer code there is a new function in EIGRP that if it thinks it has detected a problem with the neighbor and is about to terminate the neighbor relationship then it will send a "goodby" message in which it sets K values to zero. The router with older code receives the goodby message but does not recognize it and reacts to the different setting of the K values in that particular message.

The K value mismatch message in itself is not anything to worry about. But it would be very helpful to find out why the tunnels are not stable and why it keeps building and terminating EIGRP neighbor relationships.

HTH

Rick

deveshkumar Fri, 06/22/2007 - 11:20

check the cpu utilisation on the opposite router of the router on which you getting this error.

Peer restarted mean other router initiated restart request. so problem is on other router.

give command

show proc cpu | exclude 0.00%__0.00%__0.00%

normally if your cpu utilsation is ofen high it will restaart the eigrp process moment it reaches 80%.

first check this and let me know.

Actions

This Discussion