2924XL and Encapsulation

Unanswered Question
Jun 20th, 2007

So we replaced a failed HP (sigh..should have had a Cisco in all along) switch with a backup Cisco 2924-XL. Performed basic config, and plugged it into our 2611 Router. Connection was just fine...THEN:

I went and enabled trunking/encapsulation on interface FastEthernet0/1 with the following (no errors):

switchport trunk encapsulation dot1q

switchport mode trunk

Our connection was fine until the above. Interface 0/0 on the router is also configured for encapsulation and now it seems the switch and router are not communicating.

When I bring it up in CNA, it shows the router as an "Unsupported Device". I downloaded and installed the latest image for this 2924XL and it installed fine...Image file: c2900xl-c3h2s-mz.120-5.WC17.bin

Any ideas? My gratitude ahead of time!

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Edison Ortiz Wed, 06/20/2007 - 07:25

What's the configuration on the router ?

Is the router performing the inter-vlan routing ?

A sanitized config from the switch and router can expedite the troubleshooting process.

glen.grant Wed, 06/20/2007 - 13:52

CNA was developed well after the 2924 which is well past end of life so it wouldn't be supported. If you are trying to trunk you will have to supply the router config so we can look at it .

srberg5219 Thu, 06/21/2007 - 06:19

My apologies..Here is the Router config:

Current configuration : 1602 bytes

!

version 12.2

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname TestBench

!

enable secret xxx

!

ip subnet-zero

!

!

!

ip audit notify log

ip audit po max-events 100

!

call rsvp-sync

!

!

!

!

!

!

!

!

interface Ethernet0/0

no ip address

half-duplex

!

interface Ethernet0/0.1

description Main Interface Network

encapsulation dot1Q 1 native

ip address 192.168.220.254 255.255.255.0

!

interface Ethernet0/0.2

encapsulation dot1Q 2

ip address 192.168.2.254 255.255.255.0

!

interface Ethernet0/0.3

encapsulation dot1Q 3

ip address 192.168.1.254 255.255.255.0

!

interface Ethernet0/0.10

description Haase-Bench

encapsulation dot1Q 10

ip address 10.10.10.254 255.255.255.0

ip helper-address 192.168.220.10

!

interface Ethernet0/0.11

description Garry's Bench

encapsulation dot1Q 11

ip address 10.11.11.254 255.255.255.0

ip helper-address 192.168.220.10

!

interface Ethernet0/0.12

description Tom's Bench

encapsulation dot1Q 12

ip address 10.12.12.254 255.255.255.0

ip helper-address 192.168.220.10

!

interface Ethernet0/0.16

description Voip Network

encapsulation dot1Q 16

ip address 192.168.16.254 255.255.255.0

ip helper-address 192.168.220.10

!

interface Ethernet0/1

no ip address

half-duplex

!

ip classless

ip route 0.0.0.0 0.0.x.x.168.220.253

ip http server

!

!

snmp-server community bench RO

snmp-server community public RO

snmp-server enable traps tty

snmp-server host 192.168.220.79 bench

!

dial-peer cor custom

!

!

!

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

srberg5219 Thu, 06/21/2007 - 06:37

Current configuration:

!

version 12.

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

!

hostname xxx

!

enable secret xxx

!

ip subnet-zero

!

interface FastEthernet0/1

switchport trunk encapsulation dot1q

switchport mode trunk

!

interface FastEthernet0/2

!

interface FastEthernet0/3

!

interface FastEthernet0/4

!

interface FastEthernet0/5

!

interface FastEthernet0/6

!

interface FastEthernet0/7

!

interface FastEthernet0/8

!

interface FastEthernet0/9

!

interface FastEthernet0/10

!

interface FastEthernet0/11

!

interface FastEthernet0/12

!

interface FastEthernet0/13

!

interface FastEthernet0/14

!

interface FastEthernet0/15

!

interface FastEthernet0/16

!

interface FastEthernet0/17

!

interface FastEthernet0/18

!

interface FastEthernet0/19

!

interface FastEthernet0/20

!

interface FastEthernet0/21

!

interface FastEthernet0/22

!

interface FastEthernet0/23

!

interface FastEthernet0/24

!

interface VLAN1

ip address 192.168.220.252 255.255.255.0

no ip directed-broadcast

no ip rou

!

ip default-gateway 192.168.220.254

snmp-server engineID local xxx

snmp-server community private RW

snmp-server community public RO

!

line con 0

transport input none

stopbits 1

line vty 0 4

password xxx

login

line vty 5 15

password

login

!

end

VLAN Name Status Ports

---- -------------------------------- --------- -----------------------------

1 default active Fa0/2, Fa0/3, Fa0/4, Fa0/5,

Fa0/6, Fa0/7, Fa0/8, Fa0/9,

Fa0/10, Fa0/11, Fa0/12, Fa0/13,

Fa0/14, Fa0/15, Fa0/16, Fa0/17,

Fa0/18, Fa0/19, Fa0/20, Fa0/21,

Fa0/22, Fa0/23, Fa0/24

1002 fddi-default active

1003 token-ring-default active

1004 fddinet-default active

1005 trnet-default active

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2

---- ----- ---------- ----- ------ ------

1 enet 100001 1500 - - - - - 0 0

1002 fddi 101002 1500 - - - - - 0 0

1003 tr 101003 1500 - - - - - 0 0

1004 fdnet 101004 1500 - - - ieee - 0 0

1005 trnet 101005 1500 - - - ibm - 0 0

Shawn2924XL#

My gratitude ahead of time!

Edison Ortiz Thu, 06/21/2007 - 06:47

You need to create all the VLANs running on the router at this switch as well.

VLAN 2,3,10,11 and 16

Once you do that, you can configure the port in the switch as dot1q trunk.

abdel_n Thu, 06/21/2007 - 07:04

Hi,

- Create needed vlans on the switch.

- Make sure you have configured .1q encapsulation in both subinterfaces in the router.

- set the default gateway on each hosts with its corresponding router subinterface ip.

- Make sure you have successfuly configured trunk ports on the switch, trunk interfaces should not appear in the output of the 'sh vlan' command as associated to a particular vlan).

Good work!

Abdel

Richard Burts Thu, 06/21/2007 - 06:50

Shawn

Your original post says that you did basic config on the switch and it was talking to the router ok. Then you configured trunking and connectivity was disrupted. I note that the router is configured to process 7 VLANs on the trunk port. Did your "basic config" include multiple VLANs?

Before you configured trunking interface Fa0/1 on the switch was an access port and was communicating with the router. What VLAN was it a member of? It would have been sending untagged frames (since it is an access port) and I assume that the router would have treated it as part of the native VLAN.

I agree with Edison that seeing the config from the switch would be helpful.

HTH

Rick

Actions

This Discussion