×

Warning message

  • Cisco Support Forums is in Read Only mode while the site is being migrated.
  • Cisco Support Forums is in Read Only mode while the site is being migrated.

VLAN AND STRIPPING- HELP

Unanswered Question
Jun 20th, 2007
User Badges:

Interface GigabitEthernet1/46- 1/48 are fiber points coming in off my Fiber equipment.


INT GIG1/1- 1/4 are going back to my Layer 3 Swtich. The fiber company wants me to give each customer its own VLAN - I know what to do for the Fiber ports (1/46-1/48 is just keep adding Addtional Vlans IE: switchport trunk allowed vlan 84,85), But I don't want to use any more then port 1-4 back to my Layer 3)


As you see I have 1 Vlan Assgined to each port back to my Switch.- How do I change that?


show run

Building configuration...


Current configuration : 3644 bytes

!

version 12.2

no service pad

service timestamps debug uptime

service timestamps log uptime

no service password-encryption

service compress-config

!

hostname AllopticSwitch

!

boot-start-marker

boot-end-marker

!

!

no aaa new-model

ip subnet-zero

!

vtp domain ''

vtp mode transparent

!

!

--More-- !

!

!

power redundancy-mode redundant

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

!

vlan access-map 64 74

action forward

vlan access-map 84 85

action forward

!

vlan internal allocation policy ascending

!

vlan 64-65,74-75,84-85

!

interface GigabitEthernet1/1

description

switchport access vlan 64

switchport mode access

!

--interface GigabitEthernet1/2

description

switchport access vlan 64

switchport mode access

!

interface GigabitEthernet1/3

description

switchport access vlan 74

switchport mode access

!

interface GigabitEthernet1/4

description

switchport access vlan 74

switchport mode access

!

interface GigabitEthernet1/5

description

switchport access vlan 84

switchport mode access

!

interface GigabitEthernet1/6

description

switchport access vlan 84

switchport mode access

!

interface GigabitEthernet1/7

!

interface GigabitEthernet1/8

!

interface GigabitEthernet1/9

!

interface GigabitEthernet1/10

!

interface GigabitEthernet1/11


!


!

interface GigabitEthernet1/44

!

interface GigabitEthernet1/45

description Alloptics-1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 64

switchport mode trunk

!

interface GigabitEthernet1/46

description All

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 64

switchport mode trunk

!

interface GigabitEthernet1/47

description All

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 74

switchport mode trunk

!

interface GigabitEthernet1/48

description City

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 84,85

switchport mode trunk

!

interface Vlan1

ip address 192.168.25.1 255.255.255.0

!

interface Vlan64

description All-1

ip address 192.168.26.1 255.255.255.0


interface Vlan65

description All-2

ip address 192.168.27.1 255.255.255.0


!

interface Vlan74

ip address 192.168.27.1 255.255.255.0

!

interface Vlan75

ip address 192.168.27.1 255.255.255.0


interface Vlan84

description CityPlattsburgh

ip address 192.168.28.1 255.255.255.0

shutdown

!

interface Vlan100

no ip address

!

interface Vlan101

no ip address

shutdown

!

interface Vlan2000

no ip address

shutdown

!

interface Vlan2500

description OFFICETEST

no ip address

shutdown

!

ip http server

no ip http secure-server

!

!

!

--More--

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Wed, 06/20/2007 - 11:26
User Badges:
  • Green, 3000 points or more

You should be able to add vlans to the trunk connecting back to the layer 3 switch


switchport trunk allowed vlan add


HTH, rate if it does

Narayan

cozyk1515 Wed, 06/20/2007 - 11:38
User Badges:

I have a ticket in with Cisco and changed my config - they said it should work but no go


vlan 50-100

!

interface GigabitEthernet1/1

description All-1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 50-69

switchport mode trunk

no cdp enable

!

interface GigabitEthernet1/2

description ALL-2

switchport access vlan 64

switchport mode access

!

interface GigabitEthernet1/3

description All-3

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 70-90

switchport mode trunk

no cdp enable

!

interface GigabitEthernet1/4

description All-4

switchport access vlan 74

switchport mode access

!

interface GigabitEthernet1/5

description

--More-- switchport access vlan 84

switchport mode access

!

interface GigabitEthernet1/6

description

switchport access vlan 84

switchport mode access

!

!

interface GigabitEthernet1/41

!

interface GigabitEthernet1/42

!

interface GigabitEthernet1/43

!

interface GigabitEthernet1/44

!

interface GigabitEthernet1/45

description All-1

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 50-69

switchport mode trunk

!

interface GigabitEthernet1/46

description All-1

--More-- switchport trunk encapsulation dot1q

switchport trunk allowed vlan 50-69

switchport mode trunk

!

interface GigabitEthernet1/47

description All-2

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 70-90

switchport mode trunk

!

interface GigabitEthernet1/48

description

switchport trunk encapsulation dot1q

switchport trunk allowed vlan 84,85

switchport mode trunk

!

interface Vlan1

ip address 192.168.25.1 255.255.255.0

!

Vlan 50 - 100 Added!!!


interface Vlan64

description All-1

ip address 192.168.26.1 255.255.255.0

!

interface Vlan74

ip address 192.168.27.1 255.255.255.0

!

interface Vlan84

description

ip address 192.168.28.1 255.255.255.0

shutdown

!

interface Vlan100

no ip address

!

interface Vlan101

no ip address

shutdown

!

interface Vlan2000

no ip address

shutdown

!

interface Vlan2500

description OFFICETEST

no ip address

shutdown

--More-- !

ip http server

no ip http secure-server

!

!


royalblues Wed, 06/20/2007 - 11:46
User Badges:
  • Green, 3000 points or more

yes it should work. you need to allow the vlans on trunks on both sides.


Can you post a simple network diagram


Narayan

Actions

This Discussion