redistributing eigrp basic question

Unanswered Question
Jun 20th, 2007
User Badges:

Hi Lads,


I need a little advise in redis eigrp in rip . attached is a visio detailing what I need to do , its been a while since i dont any of this , basically there are two router running eigrp between them and anther router connected to one of them speaking rip , I need one of the eigrp learned route to be know in rip . thanks alot , also do I need to do the reverse also ??

the serial interface are shut down this is ethernet both side of the network. thanks


attached is the config for B in the diagram.

Thanks





interface FastEthernet0/0

description ##### LAN #####

ip address 10.68.0.249 255.255.224.0

ip access-group 101 in

no ip redirects

speed 100

full-duplex


nterface Serial0/0

description ##### FRAME RELAY TO#####

bandwidth 256

no ip address

encapsulation frame-relay

no ip mroute-cache

no fair-queue

frame-relay traffic-shaping

frame-relay lmi-type ansi


nterface Serial0/0.1 point-to-point

description ##### FRAME DLCI TO #####

bandwidth 256

ip address 10.54.254.18 255.255.255.252

ip summary-address eigrp 1 10.68.0.0 255.255.0.0 5

no ip mroute-cache

frame-relay interface-dlci 17 IETF

class wexford256kcompress

frame-relay payload-compression FRF9 stac caim 0


nterface FastEthernet0/1

description *** *** 10Mbps To ***

ip address 172.17.100.2 255.255.255.252

duplex auto

speed auto


nterface Serial0/1

no ip address

shutdown


outer eigrp 1

redistribute static

network 10.0.0.0

network 200.2.20.0

network 200.2.26.0

distribute-list 1 out Serial0/0.1

no auto-summary


router rip

version 2

redistribute static metric 1 route-map RIP

network 172.17.0.0

no auto-summary


p classless

p route 0.0.0.0 0.0.0.0 172.17.100.1

p route 10.68.0.0 255.255.0.0 FastEthernet0/0 tag 5

p route 192.168.8.0 255.255.255.0 10.54.254.17

o ip http server



ap-class frame-relay *****kcompress

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay mincir 256000


ap-class frame-relay 256k

no frame-relay adaptive-shaping

frame-relay cir 256000

frame-relay bc 2560

frame-relay mincir 256000

ccess-list 101 permit tcp host 10.68.0.33 host 192.168.8.11 eq 8080

ccess-list 101 permit tcp host 10.68.0.14 host 192.168.8.11 eq 8080

ccess-list 101 permit ip any 10.47.0.0 0.0.255.255

ccess-list 101 deny tcp 10.68.0.0 0.0.255.255 any eq 8080

ccess-list 101 permit ip any any

oute-map RIP permit 10

match tag 5


nmp-server engineID local 0000000902000001966F3099

nmp-server community ********

nmp-server community ********

nmp-server community *********

nmp-server enable traps tty

anner exec ^CC



Attachment: 
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
Edison Ortiz Wed, 06/20/2007 - 08:41
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

If you want to advertise the 10.68.62.0 network over to RIP, do the following on router B:


route-map EIGRP-TO-RIP permit 10

match interface f0/0


route-map RIP-TO-EIGRP permit 10

match interface f0/1


router rip

version 2

redistribute connected route-map EIGRP-TO-RIP metric 3


router eigrp 1

redistribute connected route-map RIP-TO-EIGRP metric 1 1 1 1 1



kcornally Wed, 06/20/2007 - 09:33
User Badges:

thanks EdisonOrtiz,


could you give me a brief explanation as to what

the above is actually doing if its not too much hassle .




Edison Ortiz Wed, 06/20/2007 - 10:54
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

route-map EIGRP-TO-RIP permit 10 +++++ (create a route-map with the name)

match interface f0/0 +++++++ (match the ip address of interface fastethernet 0/0)


route-map RIP-TO-EIGRP permit 10 +++++ (same as above)

match interface f0/1


router rip

version 2

redistribute connected route-map EIGRP-TO-RIP metric 3

(redistribute connected routes that match the route-map specified above with a metric of 3)


router eigrp 1

redistribute connected route-map RIP-TO-EIGRP metric 1 1 1 1 1 (same as above)




kcornally Wed, 06/20/2007 - 13:11
User Badges:

thank EdisonOrtiz,


I really appreciate you taking the time to explain that just one final question , the match

interface command is it matching routes learned on that interface or is it redistributing the network range of the interface .


Thanks again.

Edison Ortiz Wed, 06/20/2007 - 15:52
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

The match interface is just a faster way to match a particular connected network.


Let's take your FA0/0 for instance:


interface FastEthernet0/0

description ##### LAN #####

ip address 10.68.0.249 255.255.224.0

ip access-group 101 in

no ip redirects

speed 100

full-duplex



You want to redistribute the 10.68.0.249 into a routing protocol using a route-map.


You can


a)


route-map CONNECTED permit 10

match interface f0/0


b)


ip access-list standard CONNECTED

permit 10.68.0.0 0.0.31.255


route-map CONNECTED permit 10

match ip address CONNECTED


___________


both route-maps perform the same function but using the access-list requires a bit more typing :)



kcornally Wed, 06/20/2007 - 09:53
User Badges:

thanks EdisonOrtiz,


could you give me a brief explanation as to what

the above is actually doing if its not too much hassle .




royalblues Wed, 06/20/2007 - 13:26
User Badges:
  • Green, 3000 points or more

Friend,


when you use a match interface command under the route map, it Matches routes that have their next hop out one of the interfaces specified


HTH, rate if it does

Narayan

sundar.palaniappan Wed, 06/20/2007 - 13:33
User Badges:
  • Green, 3000 points or more

Narayan,


I am afraid that's not correct. When you match and interface it only covers the IP subnet of that interface. In this case the only subnet that would be redistributed into RIP/EIGRP is the one that's configured on the interface.


HTH


Sundar

smothuku Wed, 06/20/2007 - 20:44
User Badges:
  • Silver, 250 points or more

Hi Sundar ,


I think Narayan is correct in this regard..when you speciy match interface , it distribute any routes that have their next hop out one of the interfaces specified.


I've checked it in cisco and following is the info..


match interface (IP)

To distribute any routes that have their next hop out one of the interfaces specified, use the match interface command in route-map configuration mode. To remove the match interface entry, use the no form of this command.


match interface interface-type interface-number [... interface-type interface-number]


no match interface interface-type interface-number [... interface-type interface-number]


Usage Guidelines

An ellipsis (...) in the command syntax indicates that your command input can include multiple values for the interface-type interface-number arguments.


Use the route-map global configuration command, and the match and set route-map configuration commands, to define the conditions for redistributing routes from one routing protocol into another. Each route-map command has a list of match and set commands associated with it. The match commands specify the match criteria?the conditions under which redistribution is allowed for the current route-map command. The set commands specify the set actions?the particular redistribution actions to perform if the criteria enforced by the match commands are met. The no route-map command deletes the route map.


The match route-map configuration command has multiple formats. The match commands may be given in any order, and all match commands must "pass" to cause the route to be redistributed according to the set actions given with the set commands. The no forms of the match commands remove the specified match criteria.


A route map can have several parts. Any route that does not match at least one match clause relating to a route-map command will be ignored; that is, the route will not be advertised for outbound route maps and will not be accepted for inbound route maps. If you want to modify only some data, you must configure a second route map section with an explicit match specified.


Examples

In the following example, routes that have their next hop out Ethernet interface 0 will be distributed:


route-map name

match interface ethernet 0


Note :Pl correct me if it is wrong...


Thanks,

Satish




kcornally Thu, 06/21/2007 - 03:40
User Badges:

thanks very much for all your help , it seems fine now.


thanks..


Kevin

Edison Ortiz Thu, 06/21/2007 - 05:09
User Badges:
  • Super Bronze, 10000 points or more
  • Hall of Fame,

    Founding Member

Satish,


You are correct but let me explain why my example won't involve routes being sourced from F0/0.


In the redistribute statement, I specified to only redistribute connected routes that match the route-map and I've labbed up for illustration:


Here is an ABR running ODR and OSPF


Its ODR RIB is as follow:


R1#sh ip route odr

51.0.0.0/32 is subnetted, 1 subnets

o 51.51.51.51 [160/1] via 172.16.15.2, 00:00:10, Serial0/1

[160/1] via 172.16.15.6, 00:00:10, Serial1/0

69.0.0.0/24 is subnetted, 1 subnets

o 69.69.69.0 [160/1] via 172.16.15.2, 00:00:10, Serial0/1

[160/1] via 172.16.15.6, 00:00:10, Serial1/0

o 222.22.2.0/24 [160/1] via 172.16.15.2, 00:00:10, Serial0/1

[160/1] via 172.16.15.6, 00:00:10, Serial1/0


__________________


So I have ODR enabled on S0/1 and S1/0 with the above routes. Let's say there is a spoke router running OSPF that needs reachability to the 172.16.15.2 address.


I do the following:


R1(config)#router os 1

R1(config-router)# redistribute connected route-map ODR subnets


and the route-map is:


route-map ODR permit 10

match interface Serial0/1


Now, if I go the spoke OSPF router


R4#sh ip route os

172.16.0.0/30 is subnetted, 1 subnets

O E2 172.16.15.0 [110/20] via 183.1.254.1, 00:01:23, Serial0/0


______________________________________


If I were to redistribute routes matching the source interface, then I would use the routing protocol that interface is running under, in this case ODR


R1(config-router)#redistribute odr route-map ODR subnets

R1(config-router)#


and if I go to the OSPF router:


R4#sh ip route os

51.0.0.0/32 is subnetted, 1 subnets

O E2 51.51.51.51 [110/20] via 183.1.254.1, 00:00:22, Serial0/0

69.0.0.0/24 is subnetted, 1 subnets

O E2 69.69.69.0 [110/20] via 183.1.254.1, 00:00:22, Serial0/0

O E2 222.22.2.0/24 [110/20] via 183.1.254.1, 00:00:22, Serial0/0



Actions

This Discussion