CVP VXML Server Licensing (EVAL Version)

Answered Question
Jun 21st, 2007

Hi,


When I try to license CVP 4.0 Eval Version VXML Server by using the URL http://IP:PORT/CVP/Licensing which is on my VXML Server, this URL wants me to enter username and password for CVP VoiceXML Software Activation console. But I did not define any username or password during the installation phase except Operation Console Administrator user password. Is there any default user and password for this interface or what can I do to license this eval version CVP VXML server.


Thaks to all...

Hey Mickey,


I'm in the same boat as you and was writing an email to send to our Cisco contact but decided to search the tree and I found what you need:


In C:\Cisco\CVP\VXMLServer\conf there is a file called login.properties


For me it says:


#The Login Info for Licensing and Info pages

#Fri Feb 24 12:07:34 PST 2006

Username=admin

Password=password


And it worked.


Regards,

Geoff


  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (3 ratings)
Loading.

I thought that the steps in CVP 4.0 are as follows:


1. After installation, use CVP Operations Console to add and configure the VXML Server.


2. Select 'System Id' from the configuration toolbar, click OK to confirm the question 'Fetch VoiceXML Server System Id?' System Id will be displayed. (e.g. W2FY-A241-A594-C35D)


3. Access http://www.cisco.com/go/license to request the license. You will need your PAK (product activation key). If the software you have came without the PAK, then what I'm saying here is all wrong for you. ;-)


4. Receive an email from Cisco. Save the attached license file locally.


5. Using Ops Console and select the VXML Server. Select 'File Transfer' and then 'Licensing' from the configuration toolbar.


6. In File Transfer window?s Files tab, click 'Select a license file from your local PC' and click 'Browse' button. Find and choose the saved license file. Click 'Open'.


7. Click 'Transfer' button to apply the license to the?VXML Server.


8. Restart the VXML Server.


I am very familiar with CVP 3.x but am learning the CVP 4.x stuff, and it's way more complex. I haven't seen the upside yet.


Regards,

Geoff


MickeyKnox Sat, 06/23/2007 - 02:50

Hi thanks to your reply first. But my problem is with EVAL version. The answer you have replied is for regular version and this is not working with EVAL version.


I got licence file from Cisco and some explanation how to do licence both EVAL and Regular version (you can see it below).The problem is after the installation when I try to reach this link ttp://IP:PORT/CVP/Licensing it whants username and password from me and I did not define any of them during the VXML server installation. Are they some kind of default values. Thanks...


-------------------


Activate Cisco Unified CVP 4.0 VXML Server


1. Install the software using the built-in installer executable.


2. Use the alphanumeric Installation Key during installation. When Unified CVP VXML Server 4.0 is started for the first time, it will indicate in your application server's console (and/or console log) that it needs to be activated. To activate it, visit the following URL and follow the instructions provided:


http://IP:PORT/CVP/Licensing


where IP is your application server's IP address, and PORT is the port it is listening on (usually 8080). Internet connectivity is required from the computer on which you are activating the software.

In CVP 3.1, Tomcat was listening on 8080. But from the CVP 4.0 Config guide:


"Note: 7000 is the default port number for a VoiceXML Server. The new port for Unified CVP4.0 is 7000 for both Tomcat and WebSphere with CVP4.0 VoiceXML Server."


However, since you get a response from where you go to you must be seeing something. I don't know the answer to your question really, since I don't have the EVAL kit.


With the previous version, you had to copy the License and Signature file into C:\Cisco\CVP\Server\license. Maybe you can find a similar directory.


Regards,

Geoff




OK, I've been playing with CVP VXML 4.0 today. I do see the screen called Service Activation or some such.


For me, it's on http://SERVER:7000/CVP/Licensing. Tomcat admin is on http://SERVER:7000.


I have no idea what user name and password to use, and I did not set one either. In the previous version it asked for a password to use as the Tomcat admin; but that's not done anymore - in fact, admin is an additional Tomcat package now. Makes me wonder how to set up a JNDI as in CVP 3.1, one logged into Tomcat Admin to configure the JNDI.


I do note that the licensing directory is still there - C:\Cisco\CVP\VXMLServer\licensing.


So if you have License and Signature. try copying them into that folder and restarting.


Regards,

Geoff

MickeyKnox Mon, 06/25/2007 - 00:10

Hi all,

As you said, I copied the license file under the C:\Cisco\CVP\VXMLServer\licensing directory and restarted the server but the result is the same. The license file content format like 12345-12345-12345-12345-12345,1234567-12345-12345-1234567, do you have any idea about the format maybe it is wrong. I have just asked it Cisco but I didnt get any aswer yet.


Best regards...

I am not familiar with CVP 4.x licence files, so I can't tell you what they should look like. With CVP 3.1 there were two files - a License file in XML format that you could read and a Signature file that was binary. The License file would say when it expired, the IP address, the numebr of ports, the gateway adaptors. It was an Audium licence.


If all you have is content like above, I dare say that it won't work at all.


Hey, at least you tried. ;-)


Regards,

Geoff



Correct Answer

Hey Mickey,


I'm in the same boat as you and was writing an email to send to our Cisco contact but decided to search the tree and I found what you need:


In C:\Cisco\CVP\VXMLServer\conf there is a file called login.properties


For me it says:


#The Login Info for Licensing and Info pages

#Fri Feb 24 12:07:34 PST 2006

Username=admin

Password=password


And it worked.


Regards,

Geoff


MickeyKnox Thu, 06/28/2007 - 00:16

Hi man, this was what I need and it solved my problem too, thanks...


Regards

Mickey Knox

david.macias Thu, 06/28/2007 - 06:45

If you're using a proxy cancel out of the activation screen, go to the Studio interface and under Windows > preferences > Install/Update and enter your proxy information then try it again.



david

David,


Brilliant advice - that worked perfectly, allowing me to connect OK. Unfortunately for me, it reported an error and would not allow me to licence Studio. Says that the licence has expired.


This may be due to the fact that this is on a rack system for Networkers with 192.168.x.y addressing; so when Cisco asked me for the IP address of the box to prepare the licence, I gave a 192.168 address.


I've had to change the address temporarily to an HP network address to get to the licencing server through the proxy, and it may be rejecting the activation on that basis.


Anyway, full marks sir - and thanks. I'll have to check on the CVP VXML Server to see if a similar proxy setting can be applied.


Regards,

Geoff

david.macias Thu, 06/28/2007 - 07:54

Geoff,


I'm on the same boat as you trying to activate a NFR version of VXML Server and Studio, it has been a pain working with the licenses. I had to do a manual activation for Studio and it worked, but manual failed for Server, working on that now.


david

MickeyKnox Thu, 06/28/2007 - 07:31

No man,

I successfully licansed two CVP studio and one VXML Server today and there was no any error.


Selim Budakoğlu

david.macias Thu, 06/28/2007 - 08:22

Geoff,


I got it to work, however I did not follow the procedures outlined in the Cisco email. No matter what I did I was not able to get it activated the Cisco way. Let me know if you need any assistance.


david

I now have a CVP Call Server licence and am up and running. Pretty convoluted -- and I did not even install the Reporting Server.


I'd still like to know how to make the CVP VXML Server use a proxy - most installs are not going to have a handy network cable that's outside the firewall.


Now to do some config and make a damn phone call!


Regards,

Geoff

gokulakrishnan.g Thu, 08/09/2007 - 04:54

Hi Geoff,


We are confused about the entire licensing model of CVP. We have the VXML Server/Studio license.


When you bought the solution, you got the Call Server license as well?


We are trying to implement the CVP comprehensive model and are not able to the up the SIP/IVR service since it says we don't have the port license. This we are assuming is because of the license issue I mentioned above.


Can you throw some light on this?


Thanks in advance


Gokul

I did eventually get the Manual Activation to work for both Studio and VXML Server (Audium Call Services).


Here is another tip, if the returned email looks garbled and doesn't work (invalid license format) then check your Outlook settings:

tools -> options -> preferences ->

E-mail options -> "Remove extra line breaks in plain text messages". You need to uncheck that box. The email was good all along, but it just gets garbled when it is displayed.


Actions

This Discussion