Duplex mismatch on 2950 switch

Unanswered Question
Jun 21st, 2007


We have the following scenario: A router cisco 7206VXR (NPE300) connected with a cisco WS-C2950SX-24.

The router is showing a mismatch configuration between its interface fastethernet 0/0 (on I/O card C7200-IO-FE-MII/RJ45) and the switch interface FastEthernet0/1.

The interface on the switch is configuring speed/duplex auto

And the router interfaces as following

interface FastEthernet0/0

description To LAN

ip address

ip nat inside

duplex full

no clns route-cache

We tryed to fix the issue, changing the router config to auto, but this card only support full/half duplex configuration.

Then the option was change the switch to full duplex hardcoding but when we did it the interface went down and only when we changed to auto the interface came up.

Any idea?

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
pstebner1 Thu, 06/21/2007 - 13:12

Normally on a router -> switch connection the best practice is to set them both to 100/Full. If you do this and the interface goes down, I would check/change the cabling.

Also, you could try a different switch port -it's not unheard of for one to go bad.



jedavis Thu, 06/21/2007 - 13:29

That is exactly the behavior I would expect with that configuration. Any time you have one side of a link trying to negotiate when the other side is not, the negotiating side (in this case, the switch) is going to fall back to half-duplex. You have the router set to full duplex - thus, you have a duplex mismatch.

I find it hard to believe that the router card does not support auto-negotiation. However, if it doesn't then the solution to the problem is to set the switch port to 100/full.


This Discussion