2950 please help

Unanswered Question
Jun 21st, 2007

hey folks could really use your input. i deleted my ios on my 2950 so that i could upgrade the ios to a newer one but in the middle of the upgrade i lost power, now i am tring to use xmodem to recover the ios but it gets to cccccccccc and i get $$$$$$$ and I/O error and help would really be great.

thanks

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
jedavis Thu, 06/21/2007 - 14:01

Won't those perform a tftp transfer of the boot image from rommon mode?

Jagdeep Gambhir Thu, 06/21/2007 - 16:10

Hi,

Please try again and see if it works,

From the switch: prompt, enter these commands (comments are in parenthesis):

switch: flash_init (initialize the flash)

switch: load_helper (loads any possible helper files)

switch: copy xmodem: flash: (filename should be something like:

c2950-....bin)

Then you should be able to "send" the image via xmodem from the PC you are consoled into

the switch with.

If still issue is there then I could be a bad switch.

Regards,

Jagdeep

upendra07 Fri, 06/22/2007 - 02:49

Dear,

can you reboot switch and pc.

I attched printscreen. see

command is

copy tftp flash:c3750-i5-mz.121-19.EA1c.bin

Attachment: 
rmmbminola Fri, 06/22/2007 - 03:42

hey thanks for your replies this is the command i am using

switch: copy xmodem: flash:c2950-i6q4l2-mz.121-22.EA10.bin. It starts out ok but after 10 C's then i get 6 $ and an I/O error tried many times wondering if i am missing any steps. have looked at the link for recovering from a missing flash. thanks again for your time and help. i was goig to use this switch for my ccna study but i guess i will have to use my 1924 if i cant get it up and running.

thank you very much for your time.

Jagdeep Gambhir Fri, 06/22/2007 - 05:12

Hi,

You steps seems to be ok here. Sorry, but I feel its a bad switch, needs to be RMA'd.

Good Luck for your CCNA. Feel free to contact incase any help is reqd.

Regards,

Jagdeep

rmmbminola Fri, 06/22/2007 - 05:19

thanks i got the switch a few weeks ago and it worked fine with the old ios, but i wanted to upgrade it to the newest ios , it does respone to flash_init, load_helper, and other commands but , well i guess i will have to just take the books word for the practice ?.

thank you guys for the input.

P.S next time i will think twice before erasing the ios on any cisco product.

garrett.fontenot Wed, 08/29/2012 - 05:39

The same thing happened when I was trying to replace my IOs on my 2950 switch. I got CCCCCCCC and then

$$$$$$$ and I/O error

Heres what you do to make it work.

At the switch prompt, I typed:

copy xmodem: flash:filename.bin    [ENTER]

As soon as you see CCCCC   in the terminal window.....

In Hyperterminal, from the tool bar, select Transfer -> Send File

Browse to the file, select Xmodem from the dropdown menu and select SEND

After the process has finished, type en and then boot flash:filename.bin

This will boot the .bin in your flash directory. The previous post only boots the switch that one time until it turns off. It does not put the image in the flash directory.

-->I dont know why it has to be done this way, but this was a bare to figure out. Nothing works like its suppose to though.

-This process will take a long time.  Couldnt get a faster speed then 9600

garrett.fontenot Wed, 08/29/2012 - 08:22

Yes i viewed that page when I had a 3500 switch to add the IOs on. And thought I could get it going a little faster since it was a newer switch, but ended up just messing up the flash on it and had to re format the flash like you just had me do - to get the flash to initialize lol. It works and Im happy with that.

Actions

This Discussion