Call Manager Caller ID

Unanswered Question
Jun 21st, 2007

Hello all,

We are currently running Call Manager, version 3.3(3) (Upgrading next month to 5.0)

Is there any way to specify the caller id to be displayed for outgoing calls for specific extensions, instead of the corporate number now that it displays?

Thanks in advance

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Majdi Harb Sat, 06/23/2007 - 07:42

you can go under that specific DN (extension) config page and use External Phone Number Mask.

External Phone Number Mask indicates phone number (or mask) that is used to send Caller

ID information when a call is placed from this line.

You can enter a maximum of 24 number and ?X? characters.

The Xs represent the directory number and must appear at the end of the pattern.

For example, if you specify a mask of

972813XXXX, an external call from extension 1234 displays a caller ID number of 9728131234.

but before doing this contact ur telco to make sure they activated caller id appearance for u on their PSTN switches.

hth

please remember to rate helpful posts

/majdi

brandoncheah Mon, 06/25/2007 - 10:20

Thanks for your reply..i went under the specific DN and used the external phone number mask, but it still shows the corporate number.

brandoncheah Thu, 07/05/2007 - 14:54

After doing more research and testing..there are a few more steps to what you have posted in order to make it work.

1. You have to enable auto registration on the call manager side, so that call manager assigns a valid extension in the range you specify.

2. You have to check the route pattern used to make the external call.

3. Only auto-registered devices are capable of displaying specific caller-id did's. If you manually assign an extension, your caller id is not going to display correctly.

dford333 Sun, 08/05/2007 - 15:22

well you can set your ANI up one of two ways.

you can prefix the extension in callmanager or on the router, outgoing interface

majdi has told you the easiest way of doing this, you should see the prefix for the phones for need to have the ANI changed.

also transforming your dialing plan can happen in route pattenrn also.

CM 3.3 you should be able to prefix the each DN seperately. if you are still getting the same ANI then you are striping the prefix or applying a translation pattern some way thats restricting this behavior.

brandoncheah Tue, 12/11/2007 - 09:40

Well...after completing my recent projects, this was an easy fix after doing more research.

#1 the debug isdn q931 command yielded the corporate number hitting the gateway no matter where i was dialing from.

#2 I had our telco company strip all digits so it would show only what we outputted.

#3 I checked our gateway settings in cm and low and behold - it had our corporate number in the Caller ID DN for the outbound calls settings...i changed it and it works now.

dford333 Tue, 12/11/2007 - 09:57

Have you tryed to use translation rules for you outbound calls,

you can create translation-profiles to do this.

brandoncheah Tue, 12/11/2007 - 09:59

No matter what translation rules u use, if the caller id is set on your gateway, it will not translate your outbound caller id.

mrandreas12 Wed, 12/26/2007 - 09:00

My old company was going through this exact same issue. Where we would change the External Phone Number Mask to be the 10 digit number we wanted to display on the end users phone, Instead it would only show the companies billing telephone number. Talking to the phone company thinking it was an issue on their side, they told me that they will only send the billing telephone number if they are not receiving enough digits from our equipment. (in this case we were only sending them 5 digits)or too many digits.

We ended up digging down and found that you have to have the "Use Calling Party's External Phone Number Mask" Set to "On" instead of default on the Route List Detail page of the T1 that you are trying to pass your call across. We had the route pattern set to "Use Calling Party's External Phone Number Mask" also, but the Route List was over riding that option.

Might check to make sure your Route Lists aren't set to default.

Hope this helps.

Actions

This Discussion