3560 not routing Vlan1 when two routed interfaces configured

Answered Question
Jun 22nd, 2007

Can anyone tell me why Vlan1 10.90.152.0/24 does

not show up as directly connected in the routing table?

It's also is not advertising to other routers.

When I only configure one 192.168.0.x routed interface, then

the Vlan1 shows up.

I'm missing something here...

Thanks!

Current configuration : 2731 bytes

!

version 12.2

!

ip subnet-zero

ip routing

no ip domain-lookup

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface Port-channel1

no switchport

ip address 192.168.0.5 255.255.255.252

!

interface GigabitEthernet0/1

no switchport

no ip address

channel-group 1 mode desirable

!

interface GigabitEthernet0/2

no switchport

no ip address

channel-group 1 mode desirable

!

!

interface GigabitEthernet0/48

no switchport

ip address 192.168.0.2 255.255.255.252

!

interface Vlan1

ip address 10.90.152.1 255.255.255.0

!

router eigrp 1

network 10.0.0.0

network 192.168.0.0

no auto-summary

!

ip classless

ip default-network 172.23.0.0

ip http server

!

Gateway of last resort is not set

* 172.23.0.0/16 is variably subnetted, 2 subnets, 2 masks

D 172.23.31.0/26

[90/28416] via 192.168.0.1, 00:24:31, GigabitEthernet0/48

D 172.23.30.0/24

[90/28928] via 192.168.0.1, 00:24:31, GigabitEthernet0/48

192.168.0.0/30 is subnetted, 3 subnets

D 192.168.0.8 [90/1792] via 192.168.0.6, 00:24:29, Port-channel1

C 192.168.0.0 is directly connected, GigabitEthernet0/48

C 192.168.0.4 is directly connected, Port-channel1

192.168.1.0/30 is subnetted, 1 subnets

D 192.168.1.0 [90/28672] via 192.168.0.1, 00:24:31, GigabitEthernet0/48

I have this problem too.
0 votes
Correct Answer by Edison Ortiz about 9 years 5 months ago

The interface needs to be up/up in order to install itself into the routing table. It can only be up/up if you have a port on VLAN 1 in connected state or if you create a trunk to another switch.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (2 ratings)
Loading.
Correct Answer
Edison Ortiz Fri, 06/22/2007 - 11:10

The interface needs to be up/up in order to install itself into the routing table. It can only be up/up if you have a port on VLAN 1 in connected state or if you create a trunk to another switch.

ricschaaf Sat, 06/23/2007 - 06:12

Yes, there were no clients on any ports.

It shows up once I connect a client to a Vlan1 port.

I figured it was something basic.

Thank you

vinayrajkp Fri, 06/22/2007 - 15:16

Is vlan1 shut down. What happens when you give -

int vlan 1

no shut

Try changing the ip of gi0/48 to a different subnet than int port channel 1.

ricschaaf Sat, 06/23/2007 - 06:14

Will the no shut command do the same as if I connected a client to a port on Vlan1 ?

ricschaaf Sun, 06/24/2007 - 03:05

Is there a way I can simulate having Vlan1

be up without actually having a client on a

port? I have (8) 3560's I'm testing but don't

have (8) clients I can connect to each...

Thanks

Actions

This Discussion