CB21AG High CPU Utilization

Unanswered Question

We have a problem with CB21AG cards causing high CPU utilization on WinXP. Task manager shows the CPU pegged at 100%, but the individual processes don't add up to 100%. IE, there are "missing" CPU cycles. Using Process Monitor from SysInternals, we see that NDIS (Windows network wrapper) is creating numerous DPCs and causing the CPU usage. Shutting down the wireless card fixes the problem. It's an LWAPP environment (WiSM 4.0.217), with various versions of the client drivers up to ADU 3.6.

Does anyone know anything about this?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
scottmac Fri, 06/22/2007 - 19:25

It'd be hard to say anything for certain without seeing all the test stuff ... but it sounds like old or corrupt drivers / utilities.

There are some Microsoft-side patches / updates that may be useful as well.

Try reloading the (and / or updating) the drivers & utilities. If you're using Zero Wireless Config, try (at least for experimentation) the Cisco utilities (ADU) or vice-versa. It might narrow down which specific software modules are involved.

IF you have a spare card, it might also be worth a shot ... there could be a bad software component in EPROM that's causing the problem.

I believe some of the driver/utility updates include updated firmware loads for the NIC too.

Good Luck


I am seeing this as well with one twist. I see the high CPU usage when connected to the Linksys WAP54G with my AIR-CB21AG-A-K9. When I connect to my Cisco 877W all is fine. Both are configured for WPA personal using TKIP. The linksys has the latest firmware and I am running the latest versions on my Cisco Aironet card. I have a PC connected to the Linksys using Linksys software to connect and it works fine.


This Discussion



Trending Topics: Other Wireless Mobility

client could not be authenticated
Network Analysis Module (NAM) Products
Cisco 6500 nam
reason 440 driver failure
Cisco password cracker
Cisco Wireless mode