3640 --> 2924XL Trunking Help

Unanswered Question
Jun 22nd, 2007

I've been trying to figure this one out for a long time. All I want to do is configure basic router on a stick config between my 2924xl switch and 3640 router. The 3640 has only 10Mb ethernet. I have read that this is supported for dot1q trunking some places, and that it is not in other places. Right now, I actually have it working, but using a strange config.

The way it works now is I have an IP assigned to the physical interface, even though thats not what the documentation says to do. The native VLAN is 1 on both sides.

If I do no ip address on the physical interface and configure e0/0.1 with an ip address and encapsulation dot1q 1 native, inter-vlan routing doesn't work.

The way I have it now works but the output of show interface trunk on the router displays nothing, and VTP won't work. My guess is because it doesn't truly see the trunk. It's just driving me crazy any help appreciated.

Router:

interface Ethernet0/0

description LAN

ip address 10.1.0.1 255.255.255.0

ip access-group firewall-lan in

ip nat inside

ip virtual-reassembly

ip route-cache flow

no ip mroute-cache

full-duplex

auto qos voip

service-policy output AutoQoS-Policy-UnTrust

!

interface Ethernet0/0.2

description wireless VLAN

encapsulation dot1Q 2

ip address 10.1.2.1 255.255.255.0

ip access-group firewall-lan in

ip nat inside

ip virtual-reassembly

!

interface Ethernet0/0.3

description Vonage VLAN

encapsulation dot1Q 3

ip address 10.1.3.1 255.255.255.252

ip nat inside

ip virtual-reassembly

router#show vlans

Virtual LAN ID: 1 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: Ethernet0/0

This is configured as native Vlan for the following interface(s) :

Ethernet0/0

Protocols Configured: Address: Received: Transmitted:

IP 10.1.0.1 0 2117

Other 0 640

0 packets, 0 bytes input

2757 packets, 252582 bytes output

Virtual LAN ID: 2 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: Ethernet0/0.2

Protocols Configured: Address: Received: Transmitted:

IP 10.1.2.1 12507 11668

Other 0 12

12507 packets, 2132903 bytes input

11680 packets, 9957139 bytes output

Virtual LAN ID: 3 (IEEE 802.1Q Encapsulation)

vLAN Trunk Interface: Ethernet0/0.3

Protocols Configured: Address: Received: Transmitted:

IP 10.1.3.1 467 844

Other 0 88

467 packets, 240776 bytes input

932 packets, 192375 bytes output

Switch:

sh run int fa0/1

Building configuration...

Current configuration:

!

interface FastEthernet0/1

duplex full

speed 10

switchport trunk encapsulation dot1q

switchport mode trunk

end

Switch#sh int fa0/1 switchport

Name: Fa0/1

Switchport: Enabled

Administrative mode: trunk

Operational Mode: trunk

Administrative Trunking Encapsulation: dot1q

Operational Trunking Encapsulation: dot1q

Negotiation of Trunking: Disabled

Access Mode VLAN: 0 ((Inactive))

Trunking Native Mode VLAN: 1 (default)

Trunking VLANs Enabled: ALL

Trunking VLANs Active: 1-3,69

Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0

Override vlan tag priority: FALSE

Voice VLAN: none

Appliance trust: none

Self Loopback: No

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
royalblues Sat, 06/23/2007 - 01:04

Why have you configured access-lists on the subinterfaces when you are trying to do intervlan routing using router on a stick?

joe.astorino Sun, 06/24/2007 - 08:23

I want machines on VLAN 1 to have the same inside firewall as those on VLAN 2, are you supposed to put the ACL on the physical interface or something???

mohammedmahmoud Sat, 06/23/2007 - 01:56

Hi,

There is a possibility that you have come across Caveat CSCds42715, in which the 802.1Q native VLAN keyword does not function properly.

[edit] You should either do a code upgrade or use your current setup which is fine (it was the only way to do inter-VLAN routing with Cisco IOS software versions earlier than 12.1(3)T where the native keyword wasn't there at all)

HTH,

Mohammed Mahmoud.

Actions

This Discussion