BGP, non-exist, advertise config assistance

Unanswered Question
Jun 23rd, 2007
User Badges:

I have a lab setup and I am trying to configure advertise and non-exist maps.


I have two routers "BGP" and "Edge" that are communicating via BGP. I am distributing the default route from the "BGP" router into the "Edge" router and that part is working.


I want to advertise:

2.1.1.64 0.0.0.31

out the "Edge" router if:

6.6.1.184 0.0.0.31

is not in the "Edge" route table.


But it is not working.


I would like to see the 2.1.1.64 subnet in the "BGP" router route table.


The "non-exist" subnet is not available to either router, so shouldnt I be advertising the "advertise" subnet?


Is there something other that what I have in the "Edge" router shown below needed to accomplish this?



router bgp 70

no synchronization

bgp log-neighbor-changes

network 6.6.1.184 mask 255.255.255.252

network 6.2.1.128 mask 255.255.255.224

network 2.1.1.64 mask 255.255.255.224

neighbor 6.6.1.189 remote-as 701

neighbor 6.6.1.189 version 4

neighbor 6.6.1.189 soft-reconfiguration inbound

neighbor 6.6.1.189 prefix-list 1 out

neighbor 6.6.1.189 advertise-map ADVERTISE non-exist-map NON-EXIST

no auto-summary


ip prefix-list 1 seq 5 permit 6.2.1.128/27

ip prefix-list 1 seq 6 permit 2.1.1.64/27

ip prefix-list 1 seq 10 deny 0.0.0.0/0 le 32


access-list 5 permit 0.0.0.0

access-list 60 permit 2.1.1.64 0.0.0.31

access-list 61 permit 6.6.1.184 0.0.0.31


route-map NON-EXIST permit 10

match ip address 61

!

route-map BGPtoOSPF permit 10

match ip address 5

!

route-map ADVERTISE permit 10

match ip address 60



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
sundar.palaniappan Sat, 06/23/2007 - 13:02
User Badges:
  • Green, 3000 points or more

Can you double check access list 61. Should that be.


access-list 61 permit 6.6.1.182 0.0.0.3


The WC mask of .31 doesn't appear to be correct. It looks like you are trying to track another BGP link in the non-exist map and disappearance of that route is to trigger this advertisement.


If you are still having issues then post the output of 'show ip route'.


HTH


Sundar

wilson_1234_2 Sat, 06/23/2007 - 15:17
User Badges:

Thanks for the reply Sundar.


I noticed the WC mask and thought it was incorrect, I changed it to 31.


can you explain why it is 3?


also, after putting it back to 3, I still do not see the desired subnet in the routing table:


Edge#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR


Gateway of last resort is 63.65.190.189 to network 0.0.0.0


4.0.0.0/32 is subnetted, 1 subnets

S 4.2.2.2 [1/0] via 63.65.190.189

65.0.0.0/27 is subnetted, 1 subnets

C 65.207.187.128 is directly connected, Ethernet0

10.0.0.0/24 is subnetted, 1 subnets

O 10.100.73.0 [110/20] via 65.207.187.130, 00:01:19, Ethernet0

63.0.0.0/30 is subnetted, 1 subnets

C 63.65.190.188 is directly connected, Serial0

B* 0.0.0.0/0 [20/0] via 63.65.190.189, 00:02:20






BGP>en

Password:

BGP#sh ip route

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP

D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area

N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2

E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP

i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default

U - per-user static route, o - ODR


Gateway of last resort is 20.30.40.1 to network 0.0.0.0


65.0.0.0/27 is subnetted, 1 subnets

B 65.207.187.128 [20/0] via 63.65.190.190, 00:01:47

20.0.0.0/30 is subnetted, 1 subnets

C 20.30.40.0 is directly connected, Ethernet0

63.0.0.0/30 is subnetted, 1 subnets

C 63.65.190.188 is directly connected, Serial0

S* 0.0.0.0/0 [1/0] via 20.30.40.1

JORGE RODRIGUEZ Sat, 06/23/2007 - 18:09
User Badges:
  • Green, 3000 points or more

As Sundar indicated, it needs to be 0.0.0.3 and not 0.0.0.31 based on you network

statement under bgp and mask "network 6.6.1.184 mask 255.255.255.252

,this is very important when using ACLs to get the right inversed mask.


go to this link which will explain in much more details.


http://www.mdh.se/netcenter/ct3790/ct3790_HT2005_p2/ACLs.pdf


Also, when making changes to bgp you need to do a bgp soft reset for the new changes to take effect.


http://www.cisco.com/en/US/products/ps6599/products_data_sheet09186a0080087b3a.html


Rgds


Jorge


sundar.palaniappan Sat, 06/23/2007 - 20:23
User Badges:
  • Green, 3000 points or more

Wilson,


The reason why network 2.1.1.64/27 isn't being advertised by BGP is because the Edge router does not have a route to that network in the routing table. The network statement under BGP process alone doesn't cause the router to advertise the network but it also requires a route to that network exist in the routing table.


Try adding 'ip route 2.1.1.64 255.255.224.0 (null0)' and test. You can substitute the null interface with another interface or next hop. As Jorge indicated you may have to do 'clear ip bgp soft * out' for any configuration change to take effect.


HTH


Sundar

wilson_1234_2 Sun, 06/24/2007 - 06:22
User Badges:

Thanks Sundar and Jorge,


Ok, so I understand this:


If I had two locations DR (where both the edge and BGP routers are located),


And I want to advertise the 2.1.1.64 subnet from DR when it is no longer available (site is wiped out and DR is not getting updates via MPLS connection from HQ)


Wouldnt it be removed out of the Edge router route table at that point?


Also, what are these lines doing:


ip prefix-list 1 seq 5 permit 65.207.187.128/27

ip prefix-list 1 seq 6 permit 206.113.198.64/27

ip prefix-list 1 seq 10 deny 0.0.0.0/0 le 32



Pavel Bykov Sun, 06/24/2007 - 09:11
User Badges:
  • Silver, 250 points or more

In your configuration, prefix-list lines allow only two networks (65.207.187.128/27 and 206.113.198.64/27) to be advertised to the neighbor 6.6.1.189.

wilson_1234_2 Sun, 06/24/2007 - 09:34
User Badges:

thanks, so that leaves the last question:


If BGP will not advertise the subnet unless it is in the route table of that router, and the only way it is in the route table is from the HQ site that has been wiped out,


Does that mean that if you want to advertise the subnet in the Disaster Recovery scenario, that you have to put a static route in the Edge router to make sure the router is advertised with the advertise and non exist maps?

sundar.palaniappan Sun, 06/24/2007 - 11:41
User Badges:
  • Green, 3000 points or more

That's correct!!


If you want the Edge Router to not use the static route if it's learning the network that you want to advertise from the HQ router then you can configure a floating static route aka route with a higher admin distance. This would cause the Edge router to use the static route only when the route learned from the HQ via the routing protocol disappears.


ip route 2.1.1.64 255255.255.224 200 --> 200 is the Admin distance.


HTH


Sundar

Actions

This Discussion