Switch port access and trunk

Unanswered Question
Jun 24th, 2007

can a switch port exist as below

both trunk and access ????

and what would be the purpose


switchport access vlan 201

switchport trunk encapsulation dot1q

switchport trunk native vlan 200

switchport trunk allowed vlan 1-1006 switchport mode trunk

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mahmoodmkl Sun, 06/24/2007 - 02:04


Yes a switchport can be access as well as trunk port.But it will be going to work as a access port.



maheshbalasub75 Sun, 06/24/2007 - 03:19

What would be the purpose of that config then ???

This happens to be in 650x switch and i fail to understand the purpose of the config

Appreciate any pointers


mahmoodmkl Sun, 06/24/2007 - 03:23


If u look at the config the first line makes the port in vlan 201,the secondl line makes it a trunk port,the third line the native vlan to be 200 and the fourth allows all the vlans through this port.

Well unless we know what is conected to this port we cannot say whats the purpose the config is serving.



maheshbalasub75 Sun, 06/24/2007 - 03:47

Well there is a typo mistake both the native and access vlan are 200 ...but i still am not able to understand the reason here ...im taking over from a badly documented network...any pointers appreciated as to what could be the possible applications of teh above


mahmoodmkl Sun, 06/24/2007 - 03:50


if this the case then the port is acting as a access port.



maheshbalasub75 Sun, 06/24/2007 - 04:10

What could be the conceivable uses of configuring a switch port in both access and trunk...im just confused on why such a thing can be required

Pointers appreciated


mahmoodmkl Sun, 06/24/2007 - 04:44


Sometimes this kind of configuration is needed if ur having IP Telephony in u r environment but u need to configure the port for voice vlan also.



Timor_SSS Sun, 06/24/2007 - 05:09

The IOS is known with it's problems as far as it goes with configurations. Every lector, guide, will tell you: CHECK YOUR CONFIGURATION EVERY TIME YOU ENTER NEW COMMAND. It's a bug, and there is nothing you can do. First cancel the old command and than put the new one. There is no reason for configuring a port to be both in access and trunk mode.


This Discussion