MPLS VPN question-lab environment

Unanswered Question
Jun 24th, 2007

I did it couple of times but it didnt work. I am just trying to build MPLS L3 VPN with OSPF as the PE-CE protocol, EIGRP running within the MPLS cloud and PE-PE protocol being MP-BGP. PE router perform mutual redistribution and the routing table at CE, C and PE routers are exactly the way they should be. PE routers have the right VRF table for that particular VPN. With all the routes in the routing table, I thought that a ping between C and C router should work. However they dont, and I am having some trouble to figure out the reason for this. MP-BGP also exists between PE routers and so does OSPF neighborship between PE and CE routers at both sides. Can anyone guide me the reason for failig pings?? I have tried enough .. :)

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
cisco_lad2004 Sun, 06/24/2007 - 12:27

It sounds like ur LSP path is broken.

do a sh ip cec vrf x.x.x.x and trace the tags hop by hop.

one of the classic reasons is that u might not be using Loopbacks as host addresses for BGP peering.



mrunal_47 Sun, 06/24/2007 - 13:03

Yes, I did MP-BGP peering using IP address of serial interfaces on both routers. I did not do any loopback peering using update-source. Why would you think loopback interfaces is a must in this case? I will reconfigure the lab again and test it.


mrunal_47 Sun, 06/24/2007 - 19:21

Alright, I configured loopbacks and did BGP peering between them and it works now. I just wanted to know why is this must to configure only through loopbacks?


cisco_lad2004 Sun, 06/24/2007 - 22:11

U need to have NH from PE to PE as a Host address. and therefore P2P wont give u that, only LP can.



This Discussion