Exchange 2007 UM/SIP and CallManager 5.x

Unanswered Question
Jun 25th, 2007

I went through the following document

http://www.microsoft.com/downloads/details.aspx?FamilyId=68b43d3c-7c84-4c2f-bfd7-98754970d70e&displaylang=en

I configured everything on Microsoft side and callmanager.

What I am not sure and hoping that someone have tried and successfully tested it, is how does CM talk to Exchange 2007 without any ports.

I assume that if I can ping back and forth between CM and exchange, IP connectivity is valid and the SIP trunk should work.

When I dial the VM pilot I get fast busy.

Do i have to do anything on Exchange 2007 for DTMF. How does Exchange understand the DTMF or the information passed over from CM?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
maloumar1234 Mon, 06/25/2007 - 05:18

Note: I also configured Exchange 2007 UM tab to point to CM IP address as the gateway

Tommer Catlin Thu, 06/28/2007 - 12:39

You have to have a SIP Gateway. Either using AudioCodes or and Cisco router. Basically you roll to that SIP gateway, gateway converts the call to SIP into the EUM server

Chris Deren Sun, 07/01/2007 - 06:55

Exchange UM 2007 talks to CM via the SIP trunk and if you configured it as described in the referenced document all should work fine, except the obvious missing MWI and faxing issues.

Chris

Get wireshark installed on Exchange and make sure TCP Offload Engine is disabled. When running the sniff, put a filter on the sniff by typing SIP and hit the apply button. See if you are getting any SIP conversation. Also verify that you are using 711 for the codec in the region(s). The default setting won't cut it.

If nothing comes up for SIP traffic on the Exchange server, check the route pattern and/or codecs being used on the CM side.

the problems i had with fast busy calls you Mircosoft were either a bad call pattern or the microsoft gateway not being enabled or having a different pilot number.

I am still having the problem that when a call is sent to the mirosoft voicmail it requests you to enter your number and does not go to the called number voice mail.

I have followed the cm5.1 integration doc and have used the mrg options but still have the same issue.

I now finally have it working. I followed the guide to the letter and it didn't work (fast busy). Came in after the weekend and it now does. Noone had done anything ??????

One thing missing in the guide is if you need to use auto attendant for transfers you need to put calling search spaces in the "rerouting calling search space" and "out-of-dialog-refer" all on the sip trunk.

Hope this helps !

Actions

This Discussion