SRST Call Transfer

Unanswered Question
Jun 25th, 2007
User Badges:

I'm working on a srst implementation for a customer.

This gateway is a h.323 one, the srst can work properly except call transfer. The config is as below:


call-manager-fallback

secondary-dialtone 9

max-conferences 4 gain -6

transfer-system full-consultant

ip source-address 2.2.2.2 port 2000

max-ephones 10

max-dn 30 dual-line

dialplan-pattern 1 912444.... extension-length 4

transfer-pattern .T

call-forward pattern .T

voicemail 3333

call-forward busy 3333



Internal call transfer is fine. Problem is when pstn call in, if transfer it to inside extension, the call will go back to pstn.

Lets say pstn call 1001, 1001 transfer it to 1002.


The debug isdn q931 displayed the call is transfered to 124441002, not internal 1002.

( the did number is 9124441002 ), the dial-peer strip out the prefix 9 and forward the call to pstn.


If I use transfer-system full-blind, or don't use dual line options in max-dn, the call can be transfered properly.


so it seems like the dialplan pattern is doing something for the transfer and hates my dual-line config.


My question is, when will the expand apply to the transfer call? I can't find explanation from cisco docs.


Now I'm full-blind for this, not the system :-)


I used command: supplementary-service h450.12 in voice service voip, still no luck.


Any ideas and comments for this will be appreciated.



Thanks,


Wayne

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Mon, 06/25/2007 - 08:12
User Badges:
  • Purple, 4500 points or more

Wayne,

Try the following dialplan-pattern command.


dialplan-pattern 1 9124441... extension-length 4


Hope this helps. If so, please rate the post.


Brandon

waynetall Mon, 06/25/2007 - 10:00
User Badges:

Hi Brandon,


Thank you for the reply.


I tried this before I posted here. It's still the same things as dialplan-pattern 1 912444.... ext 4


I'll rate this later.


Regards,


Wayne




Brandon Buffin Mon, 06/25/2007 - 10:35
User Badges:
  • Purple, 4500 points or more

Wayne,

Try reloading the router after changing the dialplan-pattern command.


Brandon

Actions

This Discussion