using the BGP community string

Unanswered Question

I am trying to determine what I am doing wrong when trying to set a community for BGP routes originating from my head router.

Here is the config info

network 192.168.252.0 route-map SetCommunity

route-map SetCommunity permit 10

match ip address prefix-list Filter_Remote

!

route-map SetCommunity permit 20

set community 0:19 65002:19

!

route-map SetCommunity permit 30

ip prefix-list Filter_Remote seq 10 deny 172.29.10.0/24

ip prefix-list Filter_Remote seq 20 permit 0.0.0.0/0 le 32

When I do a sh ip bgp 192.168.252.0 on a remote router I don't see the community tag.

sho ip bgp 192.168.252.0

BGP routing table entry for 192.168.252.0/24, version 103

Paths: (1 available, best #1, table Default-IP-Routing-Table)

Not advertised to any peer

13979 65002

172.26.185.1 from 172.26.185.1 (12.123.67.17)

Origin IGP, localpref 100, valid, external, best

Any ideas?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Edison Ortiz Mon, 06/25/2007 - 12:37

You need the

neighbor [neighbor ip] send-community

command under the BGP process.

I believe you want your set community statement under the route-map SetCommunity permit 10 entry (since right now line 10 isn't setting anything and line 20 isn't matching anything).

route-map SetCommunity permit 10

match ip address prefix-list Filter_Remote

set community 0:19 65002:19

!

route-map SetCommunity permit 30

mohammedmahmoud Mon, 06/25/2007 - 12:43

Hi,

Communities are not sent by default, you'll need

"neighbor send-community".

[edit] and i also agree with Jonathan on his suggestion.

HTH,

Mohammed Mahmoud.

Actions

This Discussion