Router with multiple ADSL's - Routing

Unanswered Question
Jun 25th, 2007

Hi all,

Hoping someone can assist with this.

I am setting up a 2851 with 3 x HWIC-1ADSL interfaces.

Each ADSL has it's own external IP address. What do I need to do in terms of routing in order to tell the router whatever data comes in on a given ADSL needs to go back out the same interface?

Is there a way I need to specify our ISP's default gateway address for each ADSL? (Each ADSL does have a different default gateway for the ISP)

Any assistance is greatly appreciated.

Thanks

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Paolo Bevilacqua Tue, 06/26/2007 - 00:26

Hi,

The only practical way is to use NAT. You should configure three NAT statements, one for each interface, and have three default routes.

How the default routes get installed, depends on the adsl configuration, eg, plain bridging with dhcp, PPPoE, etc.

So if you give us the specifics we can suggest something.

gregsmales Tue, 06/26/2007 - 04:00

Hi,

Thanks for your prompt response.

Each ADSL has an IPSEC site to site connection back to our primary site. One ADSL is going to be used for MS SQL data, another ADSL for VoIP, and the final ADSL for everything else.

The other thing I have noticed is that when you specify 'bandwidth 512' on a Dialer interface, then so a 'sh int Di0' in the text which is output it says 'Available Bandwidth 384 kilobits'. Why is this?

Below is the config of the 3 ATM and 3 Dialer interfaces:

interface ATM0/1/0

description SQL ADSL

bandwidth 512

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

interface ATM0/2/0

description Voice ADSL

bandwidth 512

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 2

interface ATM0/3/0

description Main ADSL

bandwidth 384

no ip address

load-interval 30

no atm ilmi-keepalive

dsl operating-mode auto

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 3

interface Dialer0

description SQL ADSL

bandwidth 512

ip address negotiated

ip access-group 101 in

ip nbar protocol-discovery

ip virtual-reassembly max-reassemblies 32

encapsulation ppp

dialer pool 1

dialer-group 1

fair-queue 64 128 256

ppp authentication chap callin

ppp chap hostname

ppp chap password

crypto map cm-sql

hold-queue 224 in

interface Dialer1

description Voice ADSL

bandwidth 512

ip address negotiated

ip access-group 102 in

no ip redirects

no ip unreachables

no ip proxy-arp

ip nbar protocol-discovery

ip virtual-reassembly max-reassemblies 32

encapsulation ppp

ip tcp header-compression iphc-format

dialer pool 2

dialer-group 2

ppp authentication chap callin

ppp chap hostname

ppp chap password

crypto map cm-voice

hold-queue 224 in

ip rtp header-compression iphc-format

interface Dialer2

description Main ADSL

bandwidth 384

ip address negotiated

ip access-group 103 in

ip nbar protocol-discovery

ip nat outside

ip virtual-reassembly max-reassemblies 32

encapsulation ppp

ip tcp header-compression iphc-format

dialer pool 3

dialer-group 3

ppp authentication chap callin

ppp chap hostname

ppp chap password

crypto map cm-main

service-policy output pol-dialer2

hold-queue 224 in

ip rtp header-compression iphc-format

Thanks

Paolo Bevilacqua Tue, 06/26/2007 - 04:41

This is all good. What matter is that you configure the following:

1. ip routing so that the VPN is established over the correct interface.

2. more ip routing, or possible policy-based routing so that the different applications will go out the correct interface and related VPN.

You can not use and ignore the bandwidth statements under dialer interface. The "available bandwidth" that it shows is related to voip QoS defaults, you can ignore that as the circuit will use anyway all the bandwidth available on the ADSL circuits. If you want to see at what speed the circuit have synced up, do "show dsl interface"

Hope this helps, please rate post if it does!

Actions

This Discussion