Enable logging to syslog server on 876

Unanswered Question
Jun 26th, 2007

Hi all,

I have been trying to get logging up and running on a 876 router but to no avail.

I have tried a lot of settings that I found on the cisco site but can't even get log messeages on my console (connected via SSH)

This is what I tried:

logging on

no logging console

no logging monitor

logging host x.x.x.x (external syslog server)

logging buffered 10000 debugging

logging buffered debugging

logging trap debugging

sh logging

I only see the messages "configured from console" on my syslog server.

Looks like I need to specify what traffic I want to log but I thought 'debugging' would cover all.

I hope anyone here can point me in the right direction.

Best regards

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Joe Clarke Tue, 06/26/2007 - 07:54

This is a correct config to send all syslog messages (and debugging output) to a syslog server. The reason you don't see messages on your console is that you have "no logging console" configured. This is actually a good thing as it cuts down on interrupts and thus CPU load. The fact that you also have "no logging monitor" configured means that you will also not see messages when you enable "terminal monitor". This may not be desirable.

If the only messages you are seeing on your syslog server are the config change messages, then those are the only messages the device is sending. Check the output of "show logg" and that should confirm it.


This Discussion