swithport mode set to access - adding any switch disables

Unanswered Question
Jun 26th, 2007

Hi,

I have a catalyst 3750g (switch 6 in a 7 switch stack) with a port on switch 6 set to

switchport mode access. This port is associated with a vlan happily working for another port in the stack (switch 1) which in turn is connected to a 3Com 16 port switch

Adding any multiport device such as a hub or switch causes the port on switch 6 ( 6/0/24) to be disabled needing the no shutdown command to bring it back to life. Directly connecting a host to the port and everything is fine.

I've checked the settings with the port in switch 1 and its exactly the same -

switchport access vlan 22

switchport mode access

speed 100

duplex full

along with a few settings about stp

So far a 24 port netgear switch, a 16 port 3com switch and a 4port hub have all deactivated the port. Any ideas why it may be doing this? I'm sure its something obvious but I can't figure it

Thanks

Paul

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
glen.grant Tue, 06/26/2007 - 09:31

If the devices you are attaching are set as auto/auto for speed and duplex and you have the port hardcoded 100/full like you do this may cause enough errors to put the port in err-disable mode , try setting the port to auto/auto instead of hardcoding the port .

cisconoobie Tue, 06/26/2007 - 09:39

Do you have spanning-tree bpduguard enable on the port?

If so you may have a host connected to the 3com that is using sometype of network bridge in their os configuration. The switch sees the bpdu's and disables the port.

Amit Singh Tue, 06/26/2007 - 09:37

Paul,

I would like to see the STP settings on the switchport. I am pretty sure that the there is something more than speed/duplex settings on the port which might cause the port to get disable. I agree with Glen, that speed and duplex might cause an issue on the port but the switchport config should reveal more info on this.

Also paste the output for " show interface 6/0/24.

HTH,

-amit singh

cisconoobie Tue, 06/26/2007 - 09:41

Paul, to fix this. Find out which computer is the culprit. Most likely they have something misconfigured.

Amit Singh Tue, 06/26/2007 - 09:44

Yes, Paul that's the main problem you had on the switchports. That's what I was expecting out of the switchport config. Glad, to know that you have serached and find out the solution for the problem. Please post in near future if need any help.

-amit singh

Actions

This Discussion