How to disallow log into personal line in IPCC Enterprise

Unanswered Question
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
David Wolgast Tue, 06/26/2007 - 11:14
User Badges:

Actually, associating the phone/DN with the PG User is only half of the equation toward making a phone/DN a valid instrument in Enterprise.


The second part is the creation of the device target & label(s). Any DN that doesn't have an associated Device Target will return an Invalid Instrument error message when logging on.


To avoid having users log on to the first DN, simply don't create that DN as a device target.

adignan Tue, 06/26/2007 - 14:26
User Badges:
  • Blue, 1500 points or more

Actually, even if a device target does not exist for the personal line, since its associated to pguser and the same phone as the acd phone it will actually still let you login. However, calls will not successfully get routed to the phone. Essentially, this can cause big problems because IPCC/ICM sees the agent as "ready" and tries to send it a call.


Cisco addressed this very issue in 7.1.4 or >


---------------------------------------

the fix you are looking for (the agent login issue) is in version ICM update 7.1.4 or >


http://www.cisco.com/web/ccbu/ICM/7/1/4/0/0/0/ICM7.1.4_Release_Notes.pdf



Bug ID = CSCsh334736 setup.request.enh Need to add registry key: RejectLoginWithoutDeviceTarget for EAPIM



The Generic path to where this DWORD is on both of the PG's is:


...\pim1\EAGENTData\Config\RejectLoginWithoutDeviceTarget


This should be a (DWORD) with default value = FALSE (0) and this needs to be changed to 1

------------------------------------------


please rate helpful posts.


adignan - berbee

Actions

This Discussion