Layer 2 QOS on Cat3560

Answered Question
Jun 26th, 2007
User Badges:

I'm installing Avaya IP phones on a Cat3560 (yes Avaya, I know..not my personal choice)

Avaya is requesting that 802.1p/Q should be enabled on the switch and each switch port should use prioritization scheme of 802.1p

What exactly do I need to configure on the 3560 switch to comform with the above request?

This is what I have configured right now:


mls qos map cos-dscp 0 8 16 24 32 46 48 54

mls qos


interface FastEthernet0/10

switchport access vlan 2136

switchport mode access

switchport voice vlan 3136

mls qos trust cos

spanning-tree portfast


Any additions needed?

Correct Answer by royalblues about 9 years 10 months ago

Friend,


IP phones generally tag the voip packets as DSCP EF (ip prec 5) and signalling as CS3


When using a cisco phone all you need to do is use the voice vlan as below

interface FastEthernet0/10

switchport access vlan XX

switchport voice vlan YY

The phone and the switch dynamically negotiate a special trunk via CDP


In Case of Avaya phone, there is no CDP and hence most of the time you are asked to configure a dot1q trunk manually

interface FastEthernet0/10

switchport access vlan XX

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan XX

switchport voice vlan YY


In switches like the 3550 the above config is required to make the voice vlan work.

But in the new 4500 switches i have seen the avaya ip phone working properly with the same set of commands that we used to configure for cisco


HTH

Narayan

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4 (1 ratings)
Loading.
royalblues Tue, 06/26/2007 - 13:15
User Badges:
  • Green, 3000 points or more

Yes that should be good enough.


Well i have seen in many docs that avaya wants us to specifically configure the port as a dot1q trunk


interface range FastEthernet1/0/1

switchport access vlan 2

switchport trunk encapsulation dot1q

switchport trunk native vlan 2

switchport mode trunk

switchport voice vlan 20

And if you want to do some queue management as well you can configure SRR on the ports


mls qos srr-queue output cos-map queue 1 threshold 3 5

mls qos srr-queue output cos-map queue 2 threshold 3 6 7

mls qos srr-queue output cos-map queue 2 threshold 2 3

mls qos srr-queue output cos-map queue 2 threshold 1 4

mls qos srr-queue output cos-map queue 3 threshold 3 2

mls qos srr-queue output cos-map queue 4 threshold 3 0

mls qos srr-queue output cos-map queue 4 threshold 1 1

!

mls qos srr-queue output dscp-map queue 1 threshold 3 46 40

mls qos srr-queue output dscp-map queue 2 threshold 3 48 56

mls qos srr-queue output dscp-map queue 2 threshold 2 24 26 28 30

mls qos srr-queue output dscp-map queue 2 threshold 1 32 34 36 38

mls qos srr-queue output dscp-map queue 3 threshold 3 16 18 20 22

mls qos srr-queue output dscp-map queue 4 threshold 3 0

mls qos srr-queue output dscp-map queue 4 threshold 1 8 10

!

mls qos queue-set output 1 threshold 2 75 85 50 400

mls qos queue-set output 1 threshold 4 15 100 50 400


And on the phone ports

queue-set 1

srr-queue bandwidth share 1 39 24 37

srr-queue bandwidth shape 5 0 0 0

priority-queue out


HTH, rate if it does

Narayan

gkushnir21 Thu, 07/12/2007 - 08:04
User Badges:

Thank you for responding to my question. I was away and couldn't check it.


But I have a follow-up question:


Avaya tells me to enable 802.1P/Q on each switchport.

How do i do that?

If I apply the following command:


switchport voice vlan 3136 dot1p


According to Cisco it means the following:


dot1p?Configure the Cisco IP Phone to use 802.1P priority tagging for voice traffic and to use the default native VLAN (VLAN 0) to carry all traffic. By default, the Cisco IP Phone forwards the voice traffic with an 802.1P priority of 5


But I don't want to use VLAN 0 to carry all my other traffic.


So, I'm a bit confused as to how to enable 802.1Q/P on my Layer 2 switch.

Correct Answer
royalblues Thu, 07/12/2007 - 08:53
User Badges:
  • Green, 3000 points or more

Friend,


IP phones generally tag the voip packets as DSCP EF (ip prec 5) and signalling as CS3


When using a cisco phone all you need to do is use the voice vlan as below

interface FastEthernet0/10

switchport access vlan XX

switchport voice vlan YY

The phone and the switch dynamically negotiate a special trunk via CDP


In Case of Avaya phone, there is no CDP and hence most of the time you are asked to configure a dot1q trunk manually

interface FastEthernet0/10

switchport access vlan XX

switchport mode trunk

switchport trunk encapsulation dot1q

switchport trunk native vlan XX

switchport voice vlan YY


In switches like the 3550 the above config is required to make the voice vlan work.

But in the new 4500 switches i have seen the avaya ip phone working properly with the same set of commands that we used to configure for cisco


HTH

Narayan

Actions

This Discussion