claering a vty line through snmp

Unanswered Question
Jun 26th, 2007
User Badges:

I tried to run the following command from opt/CSCOpx/bin

snmpset -c RWcommunity devicename .1.3.6.1.4.1.9.2.9.10.0 integer 6 and it failed with the following errror:

ld.so.1: snmpset: fatal: libnetsnmp.so.5: open failed: No such file or directory Killed.

I also tried to run snmpset from Device center and it failed with the following error:

tsClrTtyLine.0


Failed to do snmpset on the device. Please check your community string and starting OID, and try again.

I verified the community and it is correct but still failing. Any suggestions?

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
Joe Clarke Tue, 06/26/2007 - 13:26
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

You need to do:


env LD_LIBRARY_PATH=/opt/CSCOpx/lib:/opt/CSCOpx/MDC/lib snmpset -v 1 -c COMMUNITY 1.3.6.1.4.1.9.2.9.10.0 i 6

nawas Wed, 06/27/2007 - 06:08
User Badges:

Do I need to be in opt/CSCOpx/bin or i can run env LD_LIBRARY_PATH from any prompt? what if I'm using different community strings? Do I need to set env for all the community strings?

Thanks.

Joe Clarke Wed, 06/27/2007 - 07:46
User Badges:
  • Cisco Employee,
  • Hall of Fame,

    Founding Member

LD_LIBRARY_PATH is an environment variable that tells the linker where to look to find missing libraries. You can run this command from any directory provided /opt/CSCOpx/bin is in your PATH. The LD_LIBRARY_PATH does not change with different community strings.

Actions

This Discussion