Problem with connecting VG224 to CCM4.1 (SCCP)

Unanswered Question
Jun 28th, 2007

Hi

I have some problems with connecting VG224 to CCM4.1

I create a new gateway on CCM (VG244-SCCP),create one Phone with directory number. Problem is that status of this phone "Not Found" IP address blunk,and I cant make call from CCM IPPnones to VG244Phones and back.H

Here is my config:

-----------------------------------------

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

enable secret xxx

enable password xxx

!

no aaa new-model

!

resource policy

!

ip subnet-zero

no ip dhcp use vrf connected

!

voice-card 0

!

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.255.59 255.255.255.0

ip access-group 121 in

ip access-group 121 out

no snmp trap link-status

!

interface FastEthernet0/0.2

encapsulation dot1Q 700

ip address 10.10.0.4 255.255.0.0

no snmp trap link-status

!

interface FastEthernet0/1

no ip address

duplex auto

speed auto

!

interface FastEthernet0/1.1

encapsulation dot1Q 700

shutdown

no snmp trap link-status

!

ip classless

!

no ip http server

!

voice-port 2/0

!

voice-port 2/1

!

voice-port 2/2

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

!

!

sccp local FastEthernet0/0.2

sccp ccm 10.10.0.50 identifier 1 version 4.1

sccp ip precedence 1

sccp codec g711ulaw mask

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

!

!

dial-peer voice 77 voip

destination-pattern 77...

voice-class codec 1

session target ipv4:10.10.0.50

!

dial-peer voice 72 voip

destination-pattern 72...

voice-class codec 1

session target ipv4:10.10.0.2

!

dial-peer voice 1 pots

destination-pattern 1000

port 2/2

!

!

line con 0

line aux 0

line vty 0 4

password xxx

login

!

end

VG224#

---------------------------------------

sh sccp all

SCCP Admin State: UP

Gateway IP Address: 10.10.0.4, Port Number: 2000

IP Precedence: 1

User Masked Codec list: g711ulaw

Call Manager: 10.10.0.50, Port Number: 2000

Priority: N/A, Version: 4.1, Identifier: 1

SCCP application services(dspfarm profiles) are not enabled

or haven't associated to SCCP CCM group

CCM Group Identifier: 1

Description: None

Binded Interface: NONE, IP Address: NONE

Associated CCM Id: 1, Priority in this CCM Group: 1

Registration Retries: 3, Registration Timeout: 10 sec

Keepalive Retries: 3, Keepalive Timeout: 30 sec

CCM Connect Retries: 3, CCM Connect Interval: 10 sec

Switchover Method: GRACEFUL, Switchback Method: GRACEFUL_GUARD

Switchback Interval: 10 sec, Switchback Timeout: 7200 sec

Signaling DSCP value: default, Audio DSCP value: default

Total number of active session(s) 0, and connection(s) 0

Total number of active session(s) 0, and connection(s) 0

Total number of active session(s) 0, connection(s) 0, and callegs 0

SCCP Application Service(s) Statistics Summary:

Total Conferencing Sessions: 0, Connections: 0

Total Transcoding Sessions: 0, Connections: 0

Total MTP Sessions: 0, Connections: 0

Total ALG-Phone Sessions: 0, Connections: 0

Total BRI-Phone Sessions: 0, Connections: 0

Total SCCP Sessions: 0, Connections: 0

VG224#

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (1 ratings)
Loading.
lfulgenzi Thu, 06/28/2007 - 05:52

Try adding:

stcapp ccm-group 1

stcapp

that should trigger the registration.

seducer666 Thu, 06/28/2007 - 20:35

I add this commands but nothing changes,and I cant add a few commands like "bind interface FastEthernet0/0.2" in the sccp ccm group 1.

seducer666 Fri, 06/29/2007 - 01:17

Here is my new config,CCM see VG224 and analog phones,but I cant make any calls from VG to CCM and back. If look to debug it seems that call from CCM cames to VG,but phone dont ring.

77666 - CCM

77665 - VG

---------------------------------------------

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

logging buffered 8000 debugging

enable secret 5 $1$UF1Y$HZdGIlnQMiqMdEnNW06FF.

enable password 7 15141204062C20

!

no aaa new-model

!

resource policy

!

clock timezone MSK 3

clock summer-time MSK recurring last Sun Mar 3:00 last Sun Oct 2:00

ip subnet-zero

no ip dhcp use vrf connected

!

!

!

stcapp ccm-group 1

stcapp

!

voice-card 0

!

!

!

voice service voip

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.255.59 255.255.255.0

ip access-group 121 in

ip access-group 121 out

no snmp trap link-status

!

interface FastEthernet0/0.2

encapsulation dot1Q 700

ip address 10.10.0.4 255.255.0.0

no snmp trap link-status

!

interface FastEthernet0/1

ip address 10.10.0.4 255.255.255.0

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.0.1

!

no ip http server

!

logging trap debugging

access-list 1 permit 192.168.255.0 0.0.0.255

access-list 1 deny any

access-list 121 permit ip 192.168.255.0 0.0.0.255 192.168.255.0 0.0.0.255

!

!

control-plane

!

!

voice-port 2/0

cptone RU

!

voice-port 2/1

cptone RU

!

voice-port 2/2

compand-type a-law

cptone RU

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

!

!

sccp local FastEthernet0/0.2

sccp ccm 10.10.0.50 identifier 1 priority 1 version 4.1

sccp

!

sccp ccm group 1

associate ccm 1 priority 1

switchback method graceful

!

!

dial-peer voice 72 voip

destination-pattern 72...

voice-class codec 1

session target ipv4:10.10.0.2

!

dial-peer voice 77665 pots

service stcapp

port 2/2

!

!

line con 0

line aux 0

line vty 0 4

password 7 050D1F07234A45

login

!

end

--------------------------------------------

Jun 29 07:30:44.213: CallInfoMsg Info:

calling party name: Jspc`mnb @.E.

called party name: Test_Analog_Port2

calling party: 77666

called party: 77665

line instance: 1

call reference: 16857831

call type: 1

orig called pty name: Test_Analog_Port2

orig called pty: 77665

last redirecting pty name: Test_Analog_Port2

last redirecting pty: 77665

orig cdpn redirect reason: 0

last redirect reason: 0

cgpn voice mailbox:

cdpn voice mailbox:

orig cdpn voice mailbox:

last redirectvoice mailbox:

call instance: 1

call security status: 0

pres restriction bits: 0

------------------------------------------

seducer666 Fri, 06/29/2007 - 03:49

OK I chanded protocol from SCCP to MGCP, VG244 and CCM see each other, but I still cant make calls betцeen them, where can be a problem.

------------------------------------------------

version 12.4

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

service password-encryption

!

hostname VG224

!

boot-start-marker

boot-end-marker

!

logging buffered 8000 debugging

enable secret 5 $1$UF1Y$HZdGIlnQMiqMdEnNW06FF.

enable password 7 15141204062C20

!

no aaa new-model

!

resource policy

!

clock timezone MSK 3

clock summer-time MSK recurring last Sun Mar 3:00 last Sun Oct 2:00

ip subnet-zero

ip domain name xxx.org

no ip dhcp use vrf connected

!

!

voice-card 0

!

!

voice service voip

!

voice class codec 1

codec preference 1 g711ulaw

codec preference 2 g711alaw

!

!

!

interface FastEthernet0/0

no ip address

duplex auto

speed auto

!

interface FastEthernet0/0.1

encapsulation dot1Q 1 native

ip address 192.168.255.59 255.255.255.0

ip access-group 121 in

ip access-group 121 out

no snmp trap link-status

!

interface FastEthernet0/0.2

encapsulation dot1Q 700

ip address 10.10.0.4 255.255.0.0

no snmp trap link-status

!

interface FastEthernet0/1

no ip address

shutdown

duplex auto

speed auto

!

ip classless

ip route 0.0.0.0 0.0.0.0 10.10.0.1

!

no ip http server

!

logging trap debugging

access-list 1 permit 192.168.255.0 0.0.0.255

access-list 1 deny any

access-list 121 permit ip 192.168.255.0 0.0.0.255 192.168.255.0 0.0.0.255

!

!

control-plane

!

!

voice-port 2/0

cptone RU

!

voice-port 2/1

cptone RU

!

voice-port 2/2

cptone RU

!

voice-port 2/3

!

voice-port 2/4

!

voice-port 2/5

!

voice-port 2/6

!

voice-port 2/7

!

voice-port 2/8

!

voice-port 2/9

!

voice-port 2/10

!

voice-port 2/11

!

voice-port 2/12

!

voice-port 2/13

!

voice-port 2/14

!

voice-port 2/15

!

voice-port 2/16

!

voice-port 2/17

!

voice-port 2/18

!

voice-port 2/19

!

voice-port 2/20

!

voice-port 2/21

!

voice-port 2/22

!

voice-port 2/23

!

ccm-manager mgcp

no ccm-manager fax protocol cisco

!

mgcp

mgcp call-agent 10.10.0.50 service-type mgcp version 0.1

mgcp dtmf-relay voip codec all mode out-of-band

mgcp rtp unreachable timeout 1000 action notify

mgcp modem passthrough voip mode nse

mgcp package-capability rtp-package

mgcp package-capability sst-package

no mgcp timer receive-rtcp

mgcp sdp simple

mgcp fax t38 inhibit

mgcp bind control source-interface FastEthernet0/0.2

mgcp bind media source-interface FastEthernet0/0.2

!

mgcp profile default

!

!

!

dial-peer voice 72 voip

destination-pattern 72...

voice-class codec 1

session target ipv4:10.10.0.2

!

dial-peer voice 77 voip

destination-pattern 77...

voice-class codec 1

session target ipv4:10.10.0.50

!

dial-peer voice 77665 pots

description 77665

service mgcpapp

port 2/2

!

!

line con 0

line aux 0

line vty 0 4

password 7 050D1F07234A45

login

!

VG224#

-----------------------------------------------

VG224#sh ccm-manager

MGCP Domain Name: VG224.xxx.org

Priority Status Host

============================================================

Primary Registered 10.10.0.50

First Backup None

Second Backup None

Current active Call Manager: 10.10.0.50

Backhaul/Redundant link port: 2428

Failover Interval: 30 seconds

Keepalive Interval: 15 seconds

Last keepalive sent: 15:47:11 MSK Jun 29 2007 (elapsed time: 00:00:13)

Last MGCP traffic time: 15:47:11 MSK Jun 29 2007 (elapsed time: 00:00:13)

Last failover time: None

Last switchback time: None

Switchback mode: Graceful

MGCP Fallback mode: Not Selected

Last MGCP Fallback start time: None

Last MGCP Fallback end time: None

MGCP Download Tones: Disabled

Configuration Error History:

FAX mode: disable

VG224#

-----------------------------------------------

----------------------------------------------

lfulgenzi Fri, 06/29/2007 - 04:49

MGCP has it's own tricks to look out for. For example, the device name in CCM has to match exactly the hostname+domain name of the router/gateway.

Stick with one protocol and get through that first is my opinion.

I see that you have ACLs on your interfaces. The first thing I would do is remove any ACLs to ensure you can get this working. Minimally, have logging enabled on your ACLs so you can see which ones are being hit.

rsiddon Fri, 09/21/2007 - 13:11

I had to enter the sti to the dial peer from the config documents:

As soon as I added the service to the dial peer, the port registered and I can place calls.

stcapp ccm-group 1

stcapp

!

dial-peer voice 102 pots

service stcapp

port 2/2

rvincent Fri, 11/16/2007 - 09:59

try adding the following cmds:

stcapp ccm-group 1

stcapp

and a dial peer for each port you will use as follows:

dial-peer voice 501 pots

service stcapp

port 2/0

Rob

Actions

This Discussion