TE Tunnel won't come up

Answered Question
Jun 28th, 2007
User Badges:

I've been racking my brain on this for hours. I need a cluebat.


!R1:

!

mpls traffic-eng tunnels

mpls ldp loop-detection

pseudowire-class ATOM-E

encapsulation mpls

interworking ethernet

!

interface Tunnel1

ip unnumbered Loopback0

load-interval 30

tunnel source Loopback0

tunnel destination 200.20.55.2

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 100

!

interface Loopback0

ip address 200.x.x.x.255.255.255

!

interface GigabitEthernet0/2

ip address 200.x.x.1 255.255.255.0

media-type rj45

speed auto

duplex auto

no negotiation auto

mpls traffic-eng tunnels

mpls ip

ip rsvp bandwidth 1000

!

!

interface GigabitEthernet0/3

no ip address

media-type rj45

speed auto

duplex auto

negotiation auto

!

interface GigabitEthernet0/3.10

encapsulation dot1Q 10

no snmp trap link-status

xconnect 200.20.55.2 10 pw-class ATOM-E

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 200.20.55.1 0.0.0.0 area 0

network 200.100.55.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

mpls ldp router-id Loopback0 force

!


!R2

!

mpls traffic-eng tunnels

mpls ldp loop-detection

pseudowire-class ATOM-E

encapsulation mpls

interworking ethernet

!

interface Tunnel1

ip unnumbered Loopback0

load-interval 30

tunnel source Loopback0

tunnel destination 200.20.55.1

tunnel mode mpls traffic-eng

tunnel mpls traffic-eng priority 7 7

tunnel mpls traffic-eng bandwidth 100

!

interface Loopback0

ip address 200.x.x.2 255.255.255.255

!

interface GigabitEthernet0/2

ip address 200.x.x.2 255.255.255.0

media-type rj45

speed auto

duplex auto

negotiation auto

mpls traffic-eng tunnels

mpls ip

ip rsvp bandwidth 1000

!

interface GigabitEthernet0/3

no ip address

media-type rj45

speed auto

duplex auto

negotiation auto

!

interface GigabitEthernet0/3.20

encapsulation dot1Q 20

no snmp trap link-status

xconnect 200.20.55.1 10 pw-class ATOM-E

!

router ospf 100

log-adjacency-changes

redistribute connected subnets

network 200.20.55.2 0.0.0.0 area 0

network 200.100.55.0 0.0.0.255 area 0

mpls traffic-eng router-id Loopback0

mpls traffic-eng area 0

!

mpls ldp router-id Loopback0 force

!


R1's loopback can ping R2's loopback:


R1#ping ip 200.20.55.2 source lo0


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 200.20.55.2, timeout is 2 seconds:

Packet sent with a source address of 200.20.55.1

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/1 ms

R1#


R2's loopback can ping R1's loopback:


R2#ping ip 200.20.55.1 source lo0


Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 200.20.55.1, timeout is 2 seconds:

Packet sent with a source address of 200.20.55.2

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms

R2#


All looks well, but the TE tunnels are up/down and I can't for the life of me figure out why!


R1#show ip int brie | incl Tun

Tunnel1 200.20.55.1 YES TFTP up down

R1#


R2#show ip int brie | incl Tun

Tunnel1 200.20.55.2 YES TFTP up down

R2#



Correct Answer by swaroop.potdar about 10 years 2 days ago

Good...

You can try using different path options and see the difference.


You can also try going through this document to play around with the advanced topics in TE.


http://www.cisco.com/en/US/tech/tk436/tk428/technologies_white_paper09186a00800a4472.shtml


HTH-Cheers,

Swaroop

Correct Answer by swaroop.potdar about 10 years 2 days ago

1) When you issue the "show mpls traffic-eng tunn" you will see the error why the tunnel is not setup. It will say Invalid Path option.


To solve it you will have to define a path-option for the TE tunnel, so that it can use it to setup the path till the destination.


2) And also you tunnel destination is to be the loopback of the other router. you can use the interface address in the explicit path option.


HTH-Cheers,

Swaroop

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (2 ratings)
Loading.
Correct Answer
swaroop.potdar Thu, 06/28/2007 - 17:34
User Badges:
  • Blue, 1500 points or more

1) When you issue the "show mpls traffic-eng tunn" you will see the error why the tunnel is not setup. It will say Invalid Path option.


To solve it you will have to define a path-option for the TE tunnel, so that it can use it to setup the path till the destination.


2) And also you tunnel destination is to be the loopback of the other router. you can use the interface address in the explicit path option.


HTH-Cheers,

Swaroop

jlixfeld Thu, 06/28/2007 - 17:36
User Badges:

Figured it out from other posts:


Need "tunnel mpls traffic-eng path-option 1 dynamic" on the tunnel interface. No configuration examples specified this.

Actions

This Discussion