DFM Reachability Error

Unanswered Question

I have two devices in DFM with reachability errors that will not clear. Ping from management station to devices are fine. They show a status of "ACK". The last change for the error was in July of 2006 for both of the devices. I have tried removing one of the devices from Common Services and the device will clear from DFM but after adding it again the same error pops back into DFM. I also cannot delete the device from DFM. The delete button is greyed out. All I can do within DFM is rediscover which does nothing to remedy the problem. Any ideas from anyone?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Joe Clarke Fri, 06/29/2007 - 08:17

DFM must be able to ping EVERY IP address on a device, or it will flag that interfaces it cannot ping as being unreachable. If you do not want that behavior, you will either need to unmanage those unpingable interfaces, contact the TAC to get the fix for CSCsb48643, or upgrade to LMS 3.0 which has this fix integrated into the Device Details GUI.

Joe Clarke Fri, 06/29/2007 - 09:01

Then there must be a problem with the SNMP queries to these devices. Check the config to make sure there are no views applied to the community strings that could be filtering out important objects. If not, the easiest way to troubleshoot this is with a sniffer trace. By default, if you leave a sniffer trace running for eight minutes, it should pick up two DFM polling cycles. Analyzing the request/response times and the error statuses returned might reveal the problem.

Joe Clarke Fri, 06/29/2007 - 12:33

This isn't very helpful. Please disable SNMP packet debugging on this device, perform another sniffer trace filtering on ICMP and SNMP to one device only, then post the binary sniffer trace file.

Joe Clarke Mon, 07/02/2007 - 08:31

Times between request and response as well as the SNMP errstat codes, and potentially misleading response values.

All times seem to be well within what I'd think would be reasonable and SNMP errstat codes for all requests and responses is "noError (0)" and error-index is always 0. Does the reachability error I am getting point to an SNMP or ICMP related problem? Both of the devices I am having this problem with have the exact same duration. I rebooted one of the devices and DFM was aware of the reboot. I've taken both interfaces listed for one of the devices and unmanaged both of them to again see if this would clear the problem and it has not. They just remain in an ACK state and I cannot clear them.

Joe Clarke Thu, 07/05/2007 - 09:51

Without seeing the complete picture (i.e. screenshots from DFM, full version and config details from the devices, full sniffer traces, DFM logs, etc.) I cannot say for certain where the problem lies. If you cannot share this information on the forum, I suggest you open a TAC service request so that they can analyze this in more details.

I was able to rid myself of these messages with the help of TAC. I had to perform a few steps which included opening an "epm command shell", identifying the errors and manually removing them from the database. Ultimately, the problem was incorrect IP address information for the devices that should have been fixed by removing and readding the devices to the database. I wasn't able to get to the bottom of why that didn't work but the messages are gone.

Actions

This Discussion