Routing load balancing problem, Help!

Unanswered Question
Jun 29th, 2007
User Badges:
  • Community Spotlight Award,

    Spanish Member's Choice: May 2016

Hello, I have 3 conections to my ISP. All of them are frame relay (E1), my problem is:

I configure as follow:


interface FastEthernet0/0

ip address 10.10.10.1


ip route 0.0.0.0 0.0.0.0 10.10.10.200 (ISP IP ADDRESS)

when I configure this like that everything works well internet is fast by example the video from www.youtube.com are ok.

When I Configure the next ip route and interface as follow

interface FastEthernet0/0

ip address 10.10.10.1 255.255.255.248

ip address 20.20.20.1 255.255.255.248 secondary


ip route 0.0.0.0 0.0.0.0 10.10.10.200

ip route 0.0.0.0 0.0.0.0 20.20.20.200


everything become slowly, I put load-balancing per packect and per destination but it still the same.


Each conection is a E1.

Even when I make a Traceroute in the first case is very fast but when I add the second ip route and third is really slow.


How can I fix this problem? I want to use of all my links making load balancing


By now the only traffic is from my laptop nobody else is using this connections.


Thanks

Regards

Leo

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
mohammedmahmoud Fri, 06/29/2007 - 06:37
User Badges:
  • Green, 3000 points or more

Hi Leo,


There is either a typo error, or i can't analyze your situation, how is it that you are doing the default route to "10.10.10.200", while your FastEthernet interface is in the same subnet "10.10.10.1" and you say that you are connected to the provider via FR links, what is the IPs that you are peering with your provider with, please post the whole configuration if applicable.


BR,

Mohammed Mahmoud.

Leonardo A Pena... Fri, 06/29/2007 - 06:43
User Badges:
  • Community Spotlight Award,

    Spanish Member's Choice: May 2016

Ok my example wasn't right, here is my config

interface Ethernet4/1

ip address 200.109.243.129 255.255.255.248 secondary

ip address 200.44.154.185 255.255.255.248

no ip redirects

load-interval 30


interface Serial0/0

description Circuito 8151-0012318

bandwidth 1920

ip address 200.44.111.174 255.255.255.252

ip load-sharing per-packet

encapsulation frame-relay IETF

no ip mroute-cache

load-interval 30

serial restart-delay 0

fair-queue

frame-relay interface-dlci 350

frame-relay lmi-type ansi



ip route 0.0.0.0 0.0.0.0 200.44.111.173


It works well but whe I add next ip route fron other valid network it becomes slow


example:


ip route 0.0.0.0 0.0.0.0 200.44.111.173

ip route 0.0.0.0 0.0.0.0 200.109.247.200


thanks





Harold Ritter Fri, 06/29/2007 - 07:36
User Badges:
  • Cisco Employee,

In order to try to isolate the issue, you should you use only 200.109.247.200 as a next hop for the default route. This should tell you if the "slowness" is introduced by the new link/new ISP.


Regards,

mohammedmahmoud Fri, 06/29/2007 - 12:51
User Badges:
  • Green, 3000 points or more

Hi,


Agree with Harold's suggestion, and please try to get the results of a direct ping with 1500 datagram to all your next-hops to see if there is any source of packet loss or delay on any of the paths.


HTH,

Mohammed Mahmoud.

Actions

This Discussion