Unity Voice mail and SQL log usage

Unanswered Question
Jun 29th, 2007

The other day I received a warning about SQL SERVER LOG SPACE USED ABOV 75%. I did some research and found its related to the SQL database/transaction logs.

CAn someone give me a "Best Practice" on resolving this?

CAn I just go in there and delete the logs?

I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
vmoopeung Fri, 07/06/2007 - 08:22

Verify whether you have set the UnityDb to Auto Close and Auto Shrink. If it is set it will prevent the Weekly and Nightly SQL jobs from running correctly.

If these 2 options were set, and uncheck them and run the jobs again, this will shrink the transactional logs

Here is a list of the other stuff you have to do:


- Unchecked Resuse web pages in IE

- install ES 35 and 58

- Creat the iishelp folder and extracted the IISHelp files to deal with the w3svc error

in the NT System eventlog

- move the transaction log files from c:\ to d:\ in Enterprise manager| Databases |

UnityDb| Properties | Data Files Tab

- Right click on UnityDb | All Tasks | Shrink Database and shrink it to 30 mb but the

transactional log files would not shrink.

- Changed the SQLNightlyBackupJob and Weekly job from unityinstall to SA

- installed the new gusi and permission wizard

- If it fails run the permission wizard again

- Re-run the SQLNightlyJob and if u come across 8198 error, right click on the job | View

History | Show Step Details

- Right clicked on UnityDb | properties | Options tab

Saw that Auto Close and Auto shrink where both set.


This Discussion