transfer to voice mail from remote CME busy

Unanswered Question

I created a transfer to voice mail using an 8....


When some one wants to send direct to voice mail they can type 8 and the 4 digit extention. I changed the voice mail e164 number to be the 8.... of their extention. It works fine in the office.


I have 2 remote CME's connected over the WAN. When they call they get a busy signal. I can dial direct into the 8.... and it works but when I call the 4 digit extention it rings and the CFNA send me to the 8.... and I get a busy. I am including debug for the successful call to the ext and the failure with the CFNA. The peer address also changes?


014152: .Jun 29 15:37:07.410 CST: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 2, ConnectionId 4D6312FE25B711DCAA2A93881A531AB, SetupTime .15:36:52.240 CST Fri Jun 29 2007, PeerAddress 0413, PeerSubAddress , DisconnectCause 3 , DisconnectText no route to destination (3), ConnectTime .15:37:07.410 CST Fri Jun 29 2007, DisconnectTime .15:37:07.410 CST Fri Jun 29 2007, CallOrigin 1, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 0, ReceiveBytes 0

014153: .Jun 29 15:37:07.410 CST: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEATURE_VSA=fn:TWC,ft:06/29/2007 15:36:52.205,cgn:9080988,cdn:0413,frs:0,fid:6739,fcid:4D6312FE25B711DCAA2A93881A531AB,legID:1134

014154: .Jun 29 15:37:08.552 CST: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId 4D6312FE25B711DCAA2A93881A531AB, SetupTime .15:36:52.222 CST Fri Jun 29 2007, PeerAddress 9080988, PeerSubAddress , DisconnectCause 3 , DisconnectText no route to destination (3), ConnectTime .15:37:08.552 CST Fri Jun 29 2007, DisconnectTime .15:37:08.552 CST Fri Jun 29 2007, CallOrigin 2, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 0, ReceiveBytes 0

014155: .Jun 29 15:37:08.552 CST: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEATURE_VSA=fn:TWC,ft:06/29/2007 15:36:52.189,cgn:9080988,cdn:,frs:0,fid:6738,fcid:4D6312FE25B711DCAA2A93881A531AB,legID:1133



014160: .Jun 29 15:40:44.791 CST: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 1, ConnectionId D5A53CBC25B711DCAA3693881A531AB, SetupTime .15:40:40.801 CST Fri Jun 29 2007, PeerAddress 9080988, PeerSubAddress , DisconnectCause 10 , DisconnectText normal call clearing (16), ConnectTime .15:40:41.941 CST Fri Jun 29 2007, DisconnectTime .15:40:44.781 CST Fri Jun 29 2007, CallOrigin 2, ChargedUnits 0, InfoType 2, TransmitPackets 0, TransmitBytes 0, ReceivePackets 138, ReceiveBytes 22080

014161: .Jun 29 15:40:44.791 CST: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEATURE_VSA=fn:TWC,ft:06/29/2007 15:40:40.789,cgn:9080988,cdn:,frs:0,fid:6742,fcid:D5A53CBC25B711DCAA3693881A531AB,legID:1137

014162: .Jun 29 15:40:44.851 CST: %VOIPAAA-5-VOIP_CALL_HISTORY: CallLegType 2, ConnectionId D5A53CBC25B711DCAA3693881A531AB, SetupTime .15:40:41.761 CST Fri Jun 29 2007, PeerAddress 80413, PeerSubAddress , DisconnectCause 10 , DisconnectText normal call clearing (16), ConnectTime .15:40:41.921 CST Fri Jun 29 2007, DisconnectTime .15:40:44.851 CST Fri Jun 29 2007, CallOrigin 1, ChargedUnits 0, InfoType 2, TransmitPackets 40, TransmitBytes 1172865888, ReceivePackets 133, ReceiveBytes 21121

014163: .Jun 29 15:40:44.851 CST: %VOIPAAA-5-VOIP_FEAT_HISTORY: FEATURE_VSA=fn:TWC,ft:06/29/2007 15:40:41.742,cgn:9080988,cdn:80413,frs:0,fid:6743,fcid:D5A53CBC25B711DCAA3693881A531AB,legID:1138



  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
Loading.
Brandon Buffin Fri, 06/29/2007 - 12:40
User Badges:
  • Purple, 4500 points or more

Make sure you have the following command under telephony-service.


call-forward pattern .T


Hope this helps. If so, please rate the post.


Brandon

Brandon Buffin Fri, 06/29/2007 - 13:10
User Badges:
  • Purple, 4500 points or more

Does it work if you CFNA to the unity pilot number? This should give you the same result.


Brandon

pilot number is 9000 which does work and did work before. I get the AA asking for the ID.


the VM Transfer of 80413 does go right to the persons message and that also did work before.


If I dial 0413 it rings the phone and waits for CFNA and then gets a busy as opposed to transfering into 80413 which is the users voicemail number.


That didnot work remotly and still doesn't but does work when in the same office as the user just not from the remote CME.


Seems to be a dial peer issue but I am stuck

Brandon Buffin Fri, 06/29/2007 - 13:32
User Badges:
  • Purple, 4500 points or more

Take a look at the following post where I discuss some necessary commands for this scenario as well as a bug regarding the dialplan-pattern command and a link to the workaround. If you're getting asked for the ID, it sounds like you're hitting this bug.


http://forum.cisco.com/eforum/servlet/NetProf?page=netprof&forum=Unified%20Communications%20and%20Video&topic=IP%20Telephony&CommCmd=MB%3Fcmd%3Ddisplay_location%26location%3D.1ddeb8c1


Brandon

Well I added your recommendation.


I don't think I have that bug. I am on 12.4.11.t2 on a 2811 router.


Here is the config maybe you can see something?


isdn switch-type primary-ni

!

voice-card 0

no dspfarm

!

voice service voip

allow-connections h323 to h323

allow-connections h323 to sip

allow-connections sip to h323

allow-connections sip to sip

supplementary-service h450.12

!

interface Service-Engine1/0

ip address 172.20.12.254 255.255.255.0

service-module ip address 172.20.12.250 255.255.255.0

service-module ip default-gateway 172.20.12.254

!

router eigrp 101

network 172.21.0.0

network 172.22.0.0

auto-summary

!

ip route 0.0.0.0 0.0.0.0 x.x.50.213

ip route 172.20.12.250 255.255.255.255 Service-Engine1/0

ip route 172.21.0.0 255.255.0.0 10.1.1.21

ip route 172.22.0.0 255.255.0.0 10.1.1.22

!

!

!

!

tftp-server flash:P00403020214.bin

tftp-server flash:P00303020214.bin

tftp-server flash:P00305000301.sbn

tftp-server flash:P00503010100.bin

!

control-plane

!

!

!

voice-port 0/0/0:23

!

!

!

!

!

dial-peer voice 100 pots

destination-pattern 9.T

direct-inward-dial

port 0/0/0:23

!

dial-peer voice 9000 voip

destination-pattern 9000

session protocol sipv2

session target ipv4:172.20.12.250

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 9999 voip

destination-pattern 9999

session protocol sipv2

session target ipv4:172.20.12.250

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 1 voip

destination-pattern 0412

session protocol sipv2

session target ipv4:10.1.1.21

codec g711ulaw

no vad

!

dial-peer voice 2 voip

destination-pattern 0422

session protocol sipv2

session target ipv4:10.1.1.21

codec g711ulaw

no vad

!

dial-peer voice 3 voip

destination-pattern 220.

session protocol sipv2

session target ipv4:10.1.1.21

codec g711ulaw

no vad

!

dial-peer voice 4 voip

destination-pattern 1780

session protocol sipv2

session target ipv4:10.1.1.22

codec g711ulaw

no vad

!

dial-peer voice 5 voip

destination-pattern 1809

session protocol sipv2

session target ipv4:10.1.1.22

codec g711ulaw

no vad

!

dial-peer voice 6 voip

destination-pattern 1789

session protocol sipv2

session target ipv4:10.1.1.22

codec g711ulaw

no vad

!

dial-peer voice 7 voip

destination-pattern 7428

session protocol sipv2

session target ipv4:10.1.1.22

codec g711ulaw

no vad

!

dial-peer voice 9002 voip

destination-pattern 9002

session protocol sipv2

session target ipv4:172.20.12.250

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 9001 voip

destination-pattern 9001

session protocol sipv2

session target ipv4:172.20.12.250

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 17 voip

destination-pattern 098.

session protocol sipv2

session target ipv4:10.1.1.22

codec g711ulaw

no vad

!

dial-peer voice 12 voip

destination-pattern 0423

session protocol sipv2

session target ipv4:10.1.1.21

codec g711ulaw

no vad

!

dial-peer voice 19 voip

destination-pattern 0429

session protocol sipv2

session target ipv4:10.1.1.21

codec g711ulaw

no vad

!

dial-peer voice 8900 voip

destination-pattern 8900

session protocol sipv2

session target ipv4:172.22.12.250

dtmf-relay sip-notify

codec g711ulaw

no vad

!

dial-peer voice 8999 voip

destination-pattern 8999

session protocol sipv2

session target ipv4:172.22.12.250

dtmf-relay sip-notify

codec g711ulaw

no vad

!

!

gateway

timer receive-rtp 1200

!

sip-ua

retry options 0

mwi-server ipv4:172.20.11.254 expires 86400 port 5060 transport tcp

!

!

telephony-service

ip source-address 172.20.11.254 port 2000

voicemail 9000

max-conferences 8 gain -6

call-forward pattern .T

transfer-system full-consult

secondary-dialtone 9

login timeout 600 clear 01:00

xmltest

xmlthread 5

create cnf-files version-stamp 7960 Jun 20 2007 20:24:32


Brandon Buffin Fri, 06/29/2007 - 18:56
User Badges:
  • Purple, 4500 points or more

I don't see an 8.... dial peer, so how is the call being forwarded to this pattern?


Brandon

maharris Sat, 06/30/2007 - 12:38
User Badges:
  • Silver, 250 points or more

I think the problem might be that you should still have the user phones transfering to the voicemail pilot on cfna and cfb - the only thing the direct transfer does is provide a phone number that an attendant can dial to transfer a call to voicemail without sending the caller to the phone to be forwarded - so you use a 'dummy' lead number, create a dn for the range of user exts with the lead number added, and fwdall that number to the voicemail pilot - so all calls to voicemail go to the pilot, and the system recognizes the right mailbox to send them to based on the user ext (if the call is forwarded normally), or the dummy number you have entered as the secondary E164 number.

http://www.cisco.com/en/US/products/sw/voicesw/ps5520/products_tech_note09186a00802ab979.shtml#cue_int_ccm_exp

Mary Beth

Thanks for the advise. here is the solution that worked for me. I went back and set everyones CFNA and CFB to the Pilot number. Then I set the E164 number to their 10 digit phone DID. I then on the remote CUE users had to go into the CUE card through CLI and add


username Ted phonenumber '9999'


Seems the GUI has a bug in at least verson 2.1


That allowed the system to understand the users 4 digit extention when calling internally.


Thanks

Actions

This Discussion