Campus manager device list not as DCR

Answered Question
Jun 29th, 2007

Thanks J

In Campus manager, I am seeing a few devices that are not in the same format as the DCR.

In DCR the device list is organized per the ACS devices.

The collections look ok (I was able to get the missing items in the list by editing the collection filter per your suggestion), but I am still seeing the switches in the list by an IP Address not configured anywhere.

Like remnants of past problems maybe?

I deleted one of the switches from DCR and it still shows up in the Campus manager with the IP Address as the device name (should be hostname per DCR)

Any suggestions?

I have this problem too.
0 votes
Correct Answer by Joe Clarke about 9 years 5 months ago

Yes.

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 5 (5 ratings)
Loading.
Joe Clarke Fri, 06/29/2007 - 19:08

Temporarily break the ACS integration, and get a DCR export. Check to see if the same device is there, and if it is delete it from DCR, then re-establish ACS integration.

wilson_1234_2 Tue, 07/03/2007 - 08:10

Joe,

I have broken the integration and when I look in the DCR, I see everything as I normally would.

Not sure if you were expecting me to see only the problem devices or all of them. But origianlly I did add them all manually into DCR, not discovered.

I see everything as I do when have ACS integration in place.

The export file shows 0 items when I try to export the items.

Am I supposed to create a csv file first and export to that?

The export function does not want me to put in a file name, it wants to open an existing file.

wilson_1234_2 Tue, 07/03/2007 - 08:24

That was it,

I created the CSV file and exported the items.

I see all the items as they apprear in DCR when integration is in place.

Do you have any suggestions?

In Campus Manager, the devices are showing up with their device name being the Lowest IP Address of the device rather than the Device name in DCR

Joe Clarke Tue, 07/03/2007 - 08:40

This may be CSCsj51103 which is a bug I just found last night. I have a patch for it, but you should first enable debugging for the core module under Campus Manager > Admin > Campus Data Collection > Debugging Options, and run a new Data Collection. Make sure the log size is sufficiently large to hold all of the messages. If you see the message:

Device is already known to Campus,not processing it

In the log with being one of the devices in question, then you are hitting this bug, and you should call the TAC to get the patch.

wilson_1234_2 Tue, 07/03/2007 - 10:04

Joe,

I see the IP Address for the two devices that I have been having this problem with, along with "already known" as you described.

Do I just give them the bug CSCsj51103?

Thanks

Joe Clarke Tue, 07/03/2007 - 19:57

He just had you reinitialize the ANI database. The problem will happen again. He should have provided you the patch. You may want to re-open this SR, and request the patch.

wilson_1234_2 Wed, 07/04/2007 - 06:06

Joe,

This is what I got originally when I opened the case:

This is Maurice with Cisco. I'm the owner of your service request

606341823.

I'm sending this e-mail with my contact info.

About the bug that you mentioned in the case notes, there is no patch,

but there is a workaround,

wilson_1234_2 Thu, 07/05/2007 - 05:53

Thanks Joe,

I have the patch now and will apply it.

I have two problems left and then I should be in excellent shape on CiscoWorks.

One (i will follow up on the previous thread) is the chronic out of sync items.

An the Archive polling failures that suddenly started again.

nitinmathur Tue, 07/24/2007 - 03:57

Hi Jclarke,

I am also getting similar debug message with the Logical Discrepancy in Campus mgr as "Duplicate Sysname". TAC/DE is investigating the case and case status is "Release pending". Please suggest.

Regards,

Joe Clarke Tue, 07/24/2007 - 07:59

A duplicate sysName means that two devices in the network have the same sysName. That needs to be corrected. I'm not sure what release your SR is pending.

agiacometti Wed, 07/25/2007 - 11:22

Excelent! this solve my issues... i had reports with error from several old devices, but i can?t find find them to delete them.

When i broke the ACS integration, i start to see the old devices. And of course i delete them.

Thks

Actions

This Discussion