Need help with NAT VRF Aware

Unanswered Question
Jul 2nd, 2007

Hi. I am having some problems with VRF aware NAT. I have followed the Cisco documentation, but i'm still having problems with dynamic nat.

The scenerio is i have a VRF called CUST1 which i can NAT if i use static vrf NAT, but not dynamic. The configuration is as follows

ip nat pool CUSTA_POOL netmask

ip nat source list CUSTA_NAT pool CUSTA_POOL vrf CUSTA overload


ip route vrf CUSTA FastEthernet0/0


ip access-list standard CUSTA_NAT

permit log



interface FastEthernet0/0

description "OUTSIDE INT"

ip vrf forwarding SHARED_INT

ip address

ip nat outside

ip virtual-reassembly

duplex full



interface Ethernet2/0.1

encapsulation dot1Q 10

ip vrf forwarding CUSTA

ip address

ip nat inside

ip virtual-reassembly


When using the configuration as above i can see that NAT does not take place as i can see the real address ( on the next hop. If i use a static NAT statement like...

ip nat inside source static vrf CUSTA

It will succesfully NAT. Any help with this would be much appreciated.



I have this problem too.
0 votes
  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 0 (0 ratings)
mheusing Mon, 07/02/2007 - 04:48


With the configuration above there were some restrictions depending on platform and IOS version - including VRF to VRF NAT, if I remember correctly.

Did you have a look at the NAT virtual interface at

This should be solving your issue. The document will give you an example for static as well as dynamic NAT. All you need to do, is to adjust names and addresses, I guess.

Hope this helps!

Regards, Martin

dankennedy Mon, 07/02/2007 - 05:20

This did not solve my issue. I do have the an IOS supporting all required features. Any other ideas?



swaroop.potdar Mon, 07/02/2007 - 21:21

Hi Dan, you config in this post looks like for a NAT between a VRF and global interface, going by the "ip route".

Please do refer to which Cisco document you have been suing for the same.

If its a NAT between VRF and a Global interface, I have replied to it in the other thread. If its VRF to VRF then Martin has given the right link.




This Discussion