Problem with IP Phone stuck with network configurations and its restricted!

Unanswered Question
Jul 2nd, 2007

Hi,


I'm kinda stuck in a loop.

I have a phone which was originally registered to my CCM Cluster A and they configured the phone settings to be 'restricted'. (Using CCM4.2(3))


Now I brought this phone to my other office and needs to get it registered. However, I can't seem to clear the network config or change the TFTP as the network configuration is restricted. So i can't get it registered to remove that restriction. Loop!


I'm using a 7961 and have tried doing a factory reset. Can't do a erase config as it is disabled.


Any other things i can try?

:)


Thanks all,

Eugene

  • 1
  • 2
  • 3
  • 4
  • 5
Overall Rating: 4.5 (6 ratings)
Loading.
eug-c Mon, 07/02/2007 - 20:55

Hi Paolo,


Thanks for replying.

I never know there is another method of factory reset. :O


I will try this out as soon as I get a power cube. Any reason why this method requires a power cube?


Thanks,

Eugene



Paolo Bevilacqua Tue, 07/03/2007 - 01:52

I think, the power cube is needed only for the 7970 because the higher absorption and some interaction with the way it boots. I would try via PoE anyway and if doesn't work get the powercube later. The phones have a boot loader that (apparently) cannot be corrupted so there is no risk even when an upgrade is aborted, etc.

eug-c Tue, 07/03/2007 - 02:23

Hi,


I tried using a power cube and followed the same steps showed but I think my phone is corrupted.


When it boots up, only the first line's light flashes and the phone dies off as if there is no power. I tried with PoE and with the power cubes, all failed.


Think I probably have to RMA it.


Thanks for your help,

Eugene

Paolo Bevilacqua Tue, 07/03/2007 - 02:27

Eugene,


check it out, you have to press the # key for some more than 10 secs, perhaps 20, before the leds lit again. Only then release it and enter the sequence.


let us know!

eug-c Tue, 07/03/2007 - 03:05

Hi,


I held the # key down for about 20+ seconds, and the line lights starts to flash amber, I then keyed in the sequence (tried both) and after that the phone went dead.


I tried for both PoE and using the power cube. Both failed.


Help! :)


Thanks Paolo for following up!

Paolo Bevilacqua Tue, 07/03/2007 - 03:21

Ok, at this point you must verify the DHCP/TFTP thing.

If you have the slightest doubt that your production server is not giving these services correctly, do the TFTP32 free software method. It is really a little but invaluable piece of software needed to revive phones and more things. Remember you need to configure option 150 in it. Let us know if you have any problem in using it.

Zin.Karzazi Tue, 07/03/2007 - 03:55

would you mind trying a sniffer (ethereal) on your PC connected to you Phone. Im just interested to know where exactly the Phone get stuck.

THX

Paolo Bevilacqua Tue, 07/03/2007 - 04:00

No need for sniffer with TFTPD32 (note correct spelling now)! It has a log capabilities and will tell you all about the things the phone is doing (beside respondig).

eug-c Tue, 07/03/2007 - 05:29

Hi Paolo,


I doubt that the issue lies in the DHCP and TFTP as I have tried plugging in a new IP phone to the same port and it was able to boot up, no problems.


Looks like the phones can get corrupted after all.


Thanks for your help.

:)

Paolo Bevilacqua Tue, 07/03/2007 - 05:55

Hi Eugene,


I still have to see a corrupted and unrecoverable phone. Trust me, use TFTPD32 and go from there. If it doesn't work, I'll buy your phone "for spare parts" and you make the price :)

eug-c Thu, 07/05/2007 - 04:02

Hi Paolo,


I hope ur offer to buy my phone still stands! haha... kidding.


Okay, I setup a PC with TFTPD32 and connected the phone directly with a power cube.

My Server Interface is: 192.168.0.1

I configured the following:

IP pool starting with: 192.168.0.2

Size of pool: 10

Boot File: P00308000400

Mask: 255.255.255.0

Additional Option 150 : 192.168.0.1

And saved.


When the phone boots up, I see a msg in the log viewer:

Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:19:E8:AB:CD:EF [05/07 19:58:21.203]


And the phone powers off. After a while it will prompt for the DHCP again and powers off.


Is my setting correct?


Thanks for ur help!

:)

Paolo Bevilacqua Thu, 07/05/2007 - 04:08

See, the phone is still alive, it just wants attention.


Please try replacing "option 150" with "option 66", same 192.168.0.1 address.


Remove bootfile that is not applicable. Is this a 7960 or 7961 ?


Does TFTPD32 reply to the request ?


eug-c Thu, 07/05/2007 - 05:30

Hi,


I left the bootfile blank and replaced to option 66.


The same message is appearing and the phone shows no power... hmm... weird eh...

This is a 7961. :)


Thanks paolo for following up!

:P

Paolo Bevilacqua Thu, 07/05/2007 - 06:07

This happened to me with a 7912, until I got the right DHCP options it wanted, it kept cycling and would not accept DHCP reply.


Do you have default router in DHCP setting ?


The Log viewer should be like:


Rcvd DHCP Discover Msg for IP 0.0.0.0, Mac 00:1A:2F:49:01:90 [05/07 16:03:39.343]

DHCP: proposed address 192.168.1.201 [05/07 16:03:39.343]

Rcvd DHCP Rqst Msg for IP 0.0.0.0, Mac 00:1A:2F:49:01:90 [05/07 16:03:39.343]

Previously allocated address acked [05/07 16:03:39.343]

Connection received from 192.168.1.201 on port 49152 [05/07 16:03:41.046]

Read request for file . Mode octet [05/07 16:03:41.046]


My offer stands :)

eug-c Thu, 07/05/2007 - 06:57

Hi Paolo,


Think I'm either unlucky or i'm unlucky.

After opening TFTPD32 a couple of times, i get this :

Error 10048

Only one usage of each socket address (protocol/network address/port) is normally permitted.


Tftpd32 can not bind the DHCP port

an aplication is already listening on this port.


Sorry to trouble you so much, Paolo.

:)

Thanks man.

Paolo Bevilacqua Thu, 07/05/2007 - 07:19

Do not give up. Just reboot PC perhaps. Once TFTP3D2 is running with the right dhcp config, and the files there, it will revive the phone.

For a try, I just did it with a 7941 and deep reset.


Please do not rate me anymore on this thread as it's unfair :)

eug-c Thu, 07/05/2007 - 07:53

Well, I feel it is totally fair. It is not easy to get some help that is so quick to respond, so helpful.


Let's end the thread here.

I'll continue trying.


Thanks so much for your help!

Appreciate it alot!


:)

Eugene

sr2290723 Thu, 07/05/2007 - 23:52

Hi Paolo and Eugene,


I also tried the same way as what Eugene did. And I encounter the same problem, the phone does not get any IP. The settings is just exactly the same as you recommend. Take a look : my PC IP address is 192.168.150.2.

Then the DHCP settings :

IP Pool starting address : 192.168.150.1

Size of pool : 10

Boot file : empty

WINS/DNS Server :

I emptied it, but by default it change to 255.255.255.255

Default router :

I emptied it, but by default it change to 255.255.255.255

Mask : 255.255.255.0

Domain name : empty

Additional Option : 150 192.168.150.2


And TFTP settings :

Current directory : C:\Program Files\Tftpd32

The default load : term11.default.load and term61.default.load are put into C:\Program Files\Tftpd32\


I use cross cable also. You can see the log I attach.


Any mistake ? Thanks.


Wiyandi



Attachment: 
sr2290723 Mon, 07/09/2007 - 20:50

Hi Paolo,


Now the phones get IP address, thanks to your inputs. But any idea why it doesn't want to take the default load on TFTP ? My TFTP settings on TFTPD32 is Option 150 0x1496A8C0. My PC address is 192.168.150.20.

Or did I miss something ? Thanks


Wiyandi

Paolo Bevilacqua Tue, 07/10/2007 - 01:56

Hi, please try option 66 instead 150,with PC address in dotted decimal. If doesn't work, copy and paste here the output from "log viewer" tab.

sr2290723 Mon, 07/16/2007 - 20:54

Hi Paolo,


Still problem. I attached some screen captures about DHCP settings, TFTP settings and log, and also my IP address settings, so you can take a look.

When I tried to ping 192.168.150.1 from my PC, it's RTO / destination unreachable. It means that actually the phone doesn't have any IP Address, although it's acked. Can you attach the working configuration of yours ?


Wiyandi



Attachment: 
Paolo Bevilacqua Tue, 07/17/2007 - 02:19

Hi,


Which phone is this? When phones keep asking DHCP, it means something is not right with the reply they got. Once again, try option 150 with the same PC address in dotted decimal.

sr2290723 Wed, 07/18/2007 - 20:23

It's 7911. I've tried option 150, but the result is worse, no ACK appear in the log.


It was a normal phone, and then I press the factory reset sequence numbers (123456789*0#), after that I connect it to my PC. Is it the right way ?


Thanks


Wiyandi

Paolo Bevilacqua Thu, 07/19/2007 - 02:22

Yes. I will try that with tftpd32 and a 7911 from reset sequence. I have a suspicion, will let you know.

Actions

This Discussion